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1. Introduction 
These release notes contain a summary of the changes made for EST3 versions 3.74 
and earlier 3.7x releases. You can bypass information about the earlier versions if you 
have already updated to one of these releases. The notes may also include 
information that was not available for inclusion in the documentation or Help system 
at publication time. 
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Notes 

• Please read these notes in their entirety before attempting to install your new 
version of the 3-SDU. The topic “12. Microcode panel upgrade instructions” 
provides detailed instructions on upgrading systems using the network download 
feature. 

• The use of “x” in a model number may be used to indicate several generations of 
the product. For example 3-CPUx represents the 3-CPU, 3-CPU1 and 3-CPU3. 

2. Operating system compatibility 
3-SDU V3.74 is compatible with Microsoft Windows 2000, Windows XP Service Pack 3, 
and Windows Vista Service Pack 1. 

3. New software versions 

Table 1: New EST3 software and microcode versions 

Description Version 

3-CPUx microcode 3.70 

3-EAxC microcode 3.71 

4. Overview of changes 

4.1. What's new in version 3.71 
• Removed CHECK-IN Groups 

• Removed the EMERGENCY device type 

• Updated SDU Help 

• Changed the initial default setting for K5 on RZB12-6/3 

• Fixed issue with fire phone call-in event on RZB12-6/3 

• Fixed issue preventing TAP location substitution string transmission by 
3-MODCOM 

• Fixed issue that prevented a ZA-95 amplifier from being removed from the second 
rail slot when deleted 
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• Fixed issue with passwords being deleted from imported projects in version 3.70 

• Fixed issue with User Changed Pseudo Point Color option 

• Fixed issue that caused an error when opening a project with the Verify Project 
and Repair option checked 

• Included fixes for rule commands A1TST and other trouble tests, which showed 
valid devices as being invalid during rules compile 

4.2. What's new in version 3.72 
• Fixed missing Location Text in pager messages 

• Fixed ASU Configuration exit changing devices types of some switches, pseudo 
points, and IDC zones to LOCAL RELAY 

• Increased the maximum number of 3-MODCOM modules allowed 

• Increased the maximum number of AND groups allowed 

4.3. What's new in version 3.73 
• Added support for new 3-4/3SGYWR Control-Display Module 

• Removed restriction on duplicate serial numbers in a project 

• Fixed issue with changing to and from 3-CAB5 configuration 

• Fixed issue that prevented ASU records from deleting correctly 

• Fixed the All Upload button so that it only selects local rail modules from which 
the SDU can upload data 

• Fixed issue that caused the Input/Output Correlation Report to display duplicate 
records and incorrect responses 

• Fixed issue that caused an error when you closed the report generated by Check-
In Groups and Emergency device type changes 

• Corrected Tab key operation in the Signature loop controller configuration forms 

• Added 3-CPU Boot Code version 3.70 

• Updated Help files and fixed broken links 

• Fixed issue that caused an error when you closed the Object Without Labels 
report 

• Removed relay sounder bases from BuildingReport.com report 
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4.3. What's new in version 3.74 
• The Unsupported Devices/Groups report is fixed and now only selects Check-In 

Groups and Emergency Devices that will be removed or modified in the project 

• The MODCOM and MODCOMP configuration screen is fixed and now displays 
without causing an error 

• In SAC configuration, KPDISP can be changed or removed without causing an 
error 

• The annunicator configuration screen grid can be scrolled and the form position is 
saved 

5. Software revisions and compatibility 

5.1. 3-SDU and LRM microcode compatibility 
To stay up-to-date, you should upgrade to 3-SDU version 3.74. There is no need to 
upgrade 3-CPUx application code or bootloader code. 

Table 1: 3-SDU version 3.74 software compatibility 

LRM Oldest 
version * 

Shipping 
version 

Medium Part 
number 

3-ASU 1.4 3.4 CD 3-SDU 

3-AADC 1.4 3.41 CD 3-SDU 

3-AADC1 1.4 3.71 CD 3-SDU 

3-CPUx 1.33 3.7 CD 3-SDU 

3-EASC 3.4 3.6 CD 3-SDU 

3-EADC 3.4 3.6 CD 3-SDU 

3-FTCU 1.0 1.2 Chip 190156 

3-FTCU 1.4 3.4 Chip 190254 

3-IDC8/4 1.1 3.6 Chip 190159 

3-LDSM 1.0 3.0 Chip 190153 

3-MODCOM(P) 3.0 3.6 CD 3-SDU 

3-OPS 1.0 3.0 Chip 190158 

3-PPS 1.0 3.61 Chip 190157 

3-BPS 1.0 3.61 Chip 190157 

3-BBC 3.0 3.6 Chip 190157 

3-RS485-A/B  1.5 PAL Chip 190271 
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LRM Oldest 
version * 

Shipping 
version 

Medium Part 
number 

3-RS485-R     

3-SSDC 1.52 3.32 CD 3-SDU 

3-SDDC 2.1 3.32 CD 3-SDU 

3-SSDC1 1.52 3.7 CD 3-SDU 

3-SDDC1 2.1 3.7 CD 3-SDU 

3-SAC 3.1 3.6 CD 3-SDU 

3-ZA15 1.1** N/A Chip 190151 

 1.3 N/A PAL Chip 190191 

3-ZA20A 1.4 3.4 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA20B 1.4 3.4 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA30 1.1** N/A Chip 190151 

 1.3 N/A PAL Chip 190191 

3-ZA40A 1.4 3.4 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA40B 1.4 3.4 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA90 1.4 3.4 Chip 190252 

 1.4 1.4 PAL Chip 190191 

3-ZA95 1.4 3.4 Chip 190252 

 1.0 1.0 PAL Chip 7400068 

CRC 1.3 1.7 CD 3-SDU 

KPDISP 1.0 1.6 CD 3-SDU 

CDR-3 2.0 3.5 Chip 190071 

* Oldest version still compatible with the current version of 3-SDU 

** Version 1.12 required for standalone mode disabled feature. To obtain V1.12, 
request a deviation version for part number 190151 through Technical Support. 
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Notes 

• 3-CPUx V3.7 microcode cannot reside on the same network as earlier 3-CPUx 
microcode. To use V3.7, all panels must be upgraded to V3.7. Networks with 
3-CPU microcode version 1.4 or later can be upgraded with the 3-SDU by using 
the network download function. (See the topic “12. Microcode panel upgrade 
instructions” on page 11.) 

• The 3-CPU3 is 100 percent backward compatible with, and can be installed on the 
same network as, 3-CPU1 and 3-CPU. The 3-CPU3 and 3-CPU1 require at least 
version 1.41 microcode. 

• 3-FTCU firmware comes in two noninterchangeable forms. Part 190254 cannot be 
used to update Part 190156, and vice versa. 

5.2. 3-SDU and LRM database compatibility 
3-SDU V3.74 can be used to generate databases for the LRMs listed in the following 
table. 

Table 2: LRM microcode supported by 3-SDU V3.74 

LRM 3-SDU supported microcode versions 

3-AADC V1.4, V3.0, V3.1, V3.41 

3-AADC1 V1.4, V3.0, V3.1, V3.41, V3.6, V3.7, V3.71 

3-ASU V1.4, V3.0, V3.4 

3-CPU V1.41, V1.52, V2.0, V3.0, V3.1, V3.2, V3.41, V3.5, V3.6, V3.7 

3-EADC/EADC V3.4, V3.6 

3-MODCOM(P) V3.0, V3.1, V3.11, V3.12, V3.6 

3-SAC V3.1, V3.5, V3.6 

3-SSDC/SDDC V1.52, V2.1, V3.32 

3-SSDC1/SDDC1 V1.52, V2.1, V3.32, V3.6, V3.7, V3.71 

CRC V1.3, V1.4, V1.5, V1.6, V1.7 

KPDISP V1.0, V1.1, V1.2, V1.3, V1.4, V1.5, V1.6 

5.3. 3-CPU and LRM microcode compatibility 
The following table identifies the most recent version of LRM microcode that is 
compatible with each version of 3-CPU microcode. We recommend that you use the 
latest compatible version of LRM microcode. 
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Table 3: 3-CPU and LRM microcode compatibility 

 3-CPU microcode versions 

LRM V1.52 V2.0 V3.0 V3.1 V3.2 V3.4 V3.5 V3.6 V3.7 

3-AADC V1.4 V2.1 V2.1 V3.1 V3.1 V3.41 V3.41 V3.41 V3.41 

3-AADC1 V1.4 V2.1 V2.1 V3.1 V3.1 V3.41 V3.41 V3.6 V3.7, 
V3.71 

3-ASU V1.4 V3.4 V3.4 V3.4 V3.4 V3.4 V3.4 V3.4 V3.4 

3-EASC --- --- --- --- --- V3.4 V3.4 V3.6 V3.6 

3-EADC --- --- --- --- --- V3.4 V3.4 V3.6 V3.6 

3-MODCOM(P) --- --- V3.0 V3.12 V3.12 V3.12 V3.12 V3.6 V3.6 

3-SAC --- --- --- V3.4 V3.5 V3.5 V3.5 V3.6 V3.6 

3-SSDC V1.52 V2.1 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 

3-SDDC V1.52 V2.1 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 

3-SSDC1 V1.52 V2.1 V3.32 V3.32 V3.32 V3.6 V3.6 V3.6 V3.7, 
V3.71 

3-SDDC1 V1.52 V2.1 V3.32 V3.32 V3.32 V3.6 V3.6 V3.6 V3.7, 
V3.71 

CRC --- --- --- V1.4 V1.4 V1.4 V1.6 V1.7 V1.7 

KPDISP --- --- --- V1.4 V1.4 V1.4 V1.5 V1.6 V1.6 

Notes 

• 3-CPUx V3.7 microcode cannot reside on the same network as earlier 3-CPUx 
microcode. To use V3.7, all panels must be upgraded to V3.7. Networks with 
3-CPU microcode version 1.4 or later can be upgraded with the 3-SDU by using 
the network download function. See the topic “12. Microcode panel upgrade 
instructions”. 

• The 3-CPU3 is 100 percent backward compatible with, and can be installed on the 
same network as, 3-CPU1 and 3-CPU. The 3-CPU3 and 3-CPU1 require at least 
version 1.41 microcode. 

• 3-FTCU firmware comes in two noninterchangeable forms. Part 190254 cannot be 
used to update Part 190156, and vice versa. 

6. New in 3-SDU version 3.71 

6.1. Removal of CHECK-IN group and EMERGENCY device type 
When you attempt to open a project containing CHECK-IN groups and EMERGENCY 
device types a warning message appears. 



 

8 of 16 EST3 Version 3.74 Release Notes 

Figure 1: Check-In group warning message 

 

Clicking Yes removes these objects from your project. You will have to change any 
rules that use theses objects. This affects only Check-in groups and Emergency 
device types. 

A report is displayed showing all the CHECK-IN groups removed. All EMERGENCY 
device types will be changed to MONITOR device types. Use this information to 
modify your rules and devices. 

Figure 2: Unsupported Devices/Groups sample report 
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6.2. Objects configuration 
CHECK-IN groups are no longer available in the Objects Configuration window. 3-SDU 
versions 3.71 and later do not support CHECK-IN groups. 

6.3. 3-SxDC and 3-SxDC1 configuration 
The EMERGENCY device type is no longer available. 

6.4. RZB12-6/3 configuration 
The K5 default setting when adding a new RZB12-6 model is now Supervised Output. 

6.5. RZB12-6/3 firephone fix 
We resolved an issue where the RZB12-6/3 fire phone configuration was coming in as 
a short trouble rather than a fire phone call-in event. 

7. New in 3-SDU version 3.72 

7.1. Location text in pager message 
The issue where the Location Text was not being inserted in the pager message was 
resolved. 

7.2. ASU configuration 
We resolved the issue where exiting from the ASU Configuration dialog box changed 
the devices types of some switches, pseudo points, and IDC zones to LOCAL RELAY. 
The device types now remain as they were set. 

7.3. 3-MODCOM maximum limit 
The maximum number of 3-MODCOMs in a system has been increased from ten (10) 
to sixty (60). 

7.4. AND Group maximum limit 
The maximum number of AND groups in a system has been increased from four 
hundred and ninety-nine (499) to nine hundred and ninety-nine (999). 
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8. New in 3-SDU version 3.73 

8.1. 3SW/4LEDx4 Configuration dialog box 
The 3SW/4LEDx4 Configuration dialog box uses colored grid cells to help you identify 
the LEDs on a 3-4/3SGYWR Control-Display Module. The colors used in the dialog box 
match the LED colors and are arranged in the same order. The 3-4/3SGYWR provides 
four groups of three switches. In each group, the top switch has a green LED, the 
middle switch has a pair of LEDs (yellow-over-white), and the bottom switch has a red 
LED. 

8.2. Signature Loop Controller Configuration 
Duplicate serial numbers can exist in the project but not on the same loop. 

9. V3.71 Microcode updates 

9.1. 3-AADC1 V3.71 microcode 
Added support for the RZB12-6/3 and UIO-12. 

9.2. 3-SxDC1 V3.71 microcode 
Fixed an issue where verified detectors would go into alarm if a supervisory detector 
became active prior to the verified detector activating, even if the panel had been 
reset since the supervisory detector went active, and had since been restored.  

10. Installation and upgrade notes 

Caution: If you are installing the 3-SDU on a PC connected to a local area network 
(LAN) using Borland products, call the Technical Support Department for additional 
installation information. 

We recommend that you do not manually delete your previous version of the 3-SDU. 
Rather, let the installation program update that version to the current version. 

The 3-SDU is best run on a computer with a resolution of 1024 x 768 (or better) and 
small fonts. If any other settings are used, some of the 3-SDU dialog boxes will be 
resized. 

Only one version of the 3-SDU can be installed on your PC at one time. 
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11. Running the 3-SDU 

11.1. Overview 
Remember to install your security key in your computer's parallel (LPT1) or USB port. 
Any other devices that share this port must be plugged into the key. 

Save your project periodically as you are working on it. Export your project to backup 
storage media on a regular basis to protect your work. 

11.2. ECP gateway port selection 
See external equipment manufacturer's documentation for compatible ECP gateway 
selection. 

If an ECP port is configured on the 3-CPUx then 38.4K baud is not supported for 
download via the auxiliary ports to the 3-CPUx. However, 19.2K baud is supported. 

If an ECP gateway port is not configured on the 3-CPU then 19.2K baud is not 
supported for download via the auxiliary ports to the 3-CPUx. 38.4K baud is 
supported. The RJ-45 connector always supports 19.2K baud and 38.4K baud for 
downloading. 

12. Microcode panel upgrade instructions 

12.1. 3-CPUx version 3.7 
The new application and bootloader code must both be downloaded to ALL panels in 
the system. 

Note: Do not mix different versions of 3-CPUx microcode on the same network. By 
carefully following the steps below, an existing system can be upgraded. 

12.2. Upgrading V1.33 or lower to V3.70 
Project version numbers are embedded in each project file. Because the Save As 
command creates a new version number that is different than the embedded version, 
you must use the following procedure to install V3.70. Please follow these steps in the 
correct order to upgrade the hardware and software in your system. 

To upgrade from V1.33 or lower: 

1. Install 3-SDU version 3.74. 
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2. Choose File > Open and select your project from the Open Project dialog box. Click 
OK to open the project. 

3. Click OK to upgrade the microcode of your project. 

4. Save your project as a new version, using the Save As command on the File menu. 

5. Choose Rules > Compile to recompile your project. 

6. Choose Tools > DB Conversion > All Databases to create databases for the loop 
controllers and cabinets. 

7. Choose File > Save to save the recompiled project. 

8. Disconnect network wiring at all panels. 

9. Choose Tools > Communications and select Single Step for the Download mode. 

10. From the LRM Type Display Filter group, select 3-CPU. From the File Display Filter 
group, select Application Code and Bootloader code. (Do not include the 
3-SSDC/3-SDDC database, code, or bootstrap). 

11. Connect the laptop to a node CPU, and click Download and Start to start the 
download. 

12. From the File Display Filter group, select Database. Click Download and Start to 
start the download. 

13. Connect the laptop directly to the 3-SSDC/3-SDDC and 3-ASU to download the 
application and bootstrap code. 

14. Select database and download as required. 

15. After all nodes are upgraded, reconnect the network wiring to all panels. 

16. Using the Command Menu, restart the system. 

12.3. Upgrading V1.4 or higher to V3.70 
Project version numbers are embedded in each project file. Because the Save As 
command creates a new version number that is different than the embedded version, 
you must use the following procedure to install V3.70. Please follow these steps in the 
correct order to upgrade the hardware and software in your system. 

To upgrade from V1.4 or higher: 

1. Install 3-SDU version 3.74. 

2. Choose File > Open and select your project from the Open Project dialog box. Click 
OK to open the project. 

3. If required, click OK to upgrade the microcode of your project. 

4. Save your project as a new version, using the Save As command on the File menu. 

5. Choose Rules > Compile to recompile your project. 
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6. Choose Tools > DB Conversion > All Databases to create databases for the loop 
controllers and cabinets. 

7. Choose File > Save to save the recompiled project. 

8. Choose Tools > Communications and select Network for the Download mode. 

9. From the LRM Type Display Filter group, select 3-CPU. From the File Display Filter 
group, select Database. (Do not select the Application Code, Bootloader Code, or 
any 3-SSDC/3-SDDC options). 

10. Connect your laptop to the first CPU on the network (any node for Class A 
networks) and click Download and Start to network download version 3.70 of the 
database. 

11. From the LRM Type Display Filter group, select 3-CPU. From the File Display Filter 
group, select Application Code. (Do not select the Database, Bootloader Code, or 
any 3-SSDC/3-SDDC options). 

12. Click Download and Start to network download version 3.70 of the application 
code to all nodes. 

13. From the LRM Type Display Filter group, select 3-CPU. From the File Display Filter 
group, select Bootloader Code. (Do not select the Database, Application Code, or 
any 3-SSDC/3-SDDC options). 

14. Click Download and Start to network download version 3.70 bootloader code to 
all nodes. 

12.4. Upgrading firmware on 3-SSDC(1), 3-SDDC(1), and 
3-AADC(1) loop controllers 

Notes 

• You must upgrade the 3-CPUxs before upgrading the loop controllers. 

• Each of the steps listed below must be completed in separate download sessions. 

• The loop controllers can be upgraded using network downloads. 

• If the bootstrap download fails, or if the steps are performed out of order, you 
must cycle the power on the panel and restart the upgrade by downloading the 
bootstrap code again. 

To upgrade the loop controllers: 

1. Download the 3-SSDC/3-SDDC/3-AADC bootstrap to each LRM. (Download the 
bootstrap only; do not download the application code or database.) 

2. From the 3-LCD menu, issue a restart command for all panels. 

3. Download the 3-SSDC/3-SDDC/3-AADC application code. 



 

14 of 16 EST3 Version 3.74 Release Notes 

4. Download the 3-SSDC/3-SDDC/3-AADC loop controller databases. 

12.5. Upgrading a 3-ASU 
When upgrading a 3-ASU, it is recommended that you upgrade in the following order: 

1. Boot code 

2. Application code 

3. Database 

12.6. Upgrading a CRC or CRCXM 
When upgrading a CRC or CRCXM, it is recommended that you upgrade in the 
following order: 

1. 3-SDU application code 

2. 3-SDU database 

3. ACDB database (From the CRC Administration tab, select the Destination DB Init 
task.) 

13. 3-SDU Help 
3-SDU Help requires that you have Internet Explorer 4.0 or later installed. The 
compiled HTML help file is not compatible with other web browsers. 

14. Known issues 

14.1. Calibrate command 
The Calibrate command for EA series devices has a maximum adjustment of 40% 
dirty. When calibrating a device that has been cleaned or is new, perform the 
Calibrate command several times in succession, waiting 20 seconds between each 
calibration. 

14.2. 3-ASU 
If you receive a Code 33 Error when downloading the database to the 3-ASU, you 
must reduce the message file size or the quantity of messages. 
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14.3. Single quote (‘) character allowed in label text 
The single quote character ( ' ) remains an invalid character but is not being 
substituted when entering label text. See Table 4 below. As a result, the SDU will 
generate a syntax error when you compile the rules. To correct this, open the Object 
Configuration dialog box (Configure > Objects) and remove all single quotes that are 
part of an object’s label text.  

Note: This issue does not affect labels created using the Prefabricated Text Editor. 

Table 4: Invalid character substitution table 

This character... Is replaced with... 

(space) _ (underscore) 

* (asterisk) @ (at) 

# (pound) @ (at) 

< (less than) ( (left parenthesis) 

> (greater than) ) (right parenthesis) 

% (percent) @ (at) 

{ (left curly brace) ( (left parenthesis) 

} (right curly brace) ) (right parenthesis) 

` (back quote) . (period) 

“ (double quote) . (period) 

‘ (apostrophe) . (period) 
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