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1. Introduction 
These release notes contain a summary of the changes made for version 4.01 of 
the 3-SDU. The notes may also include information that was not available for 
inclusion in the documentation or Help system at publication time. 

Because V3.83, V3.82, and V3.80 each had a limited release, these release 
notes list changes made since V3.70 of the product. 

Notes 

• Please read these notes in their entirety before attempting to install your new 
version of the 3-SDU. For details on upgrading systems using the network 
download feature see “8. Upgrading microcode versions to 4.0” on page 18. 

• The use of “x” in a model number may indicate several generations of the 
product. For example, 3-CPUx represents the 3-CPU, 3-CPU1, and 3-CPU3. 
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• Hardware designed for use in a specific marketplace has a character at the 
end of the model number to indicate the marketplace. For example, a “C” 
indicates the Chinese marketplace. Firmware does not carry a marketplace 
designation. 

• When editing an object's messages, there are now two ways that the object's 
location message can be specified. Traditional LCDs like the 3-LCD,  
3-LCD-AU, and 3-LCD-AU2 show the location message on two lines of 21 
characters each. The 3-LCDXL and 3-LCDXL1 show the location message on 
a single line of 40 characters. If a project contains only traditional LCDs, then 
the location message is entered in the “Two-Line Display” area. If a project 
contains only 3-LCDXL or 3-LCDXL1 displays, then the location message is 
entered in the “Single-Line Display” area. If a project contains a mixture of 
both types of LCDs, both areas of entry are enabled. Storing two versions of 
text in the 3-CPU database would require too much space, so the location 
text should be formatted to be readable on both types of displays. 

A new check added to the precompile segment of Rules Compile generates 
warnings for each object message that exceeds 40 characters. 

1.1 New software versions 

3-SDU version 4.01 includes new updated firmware for the products listed in 
Table 1. Note: Microcode 4.0 versions include all previous version features. 

Table 1: New EST3 software and microcode versions 

Description Version 

3-CPUx microcode 4.0 

3-EAxC microcode 4.0 

3-SxDC1 microcode 4.0 

1.2 Contacting technical support 

Contact technical support if you encounter any difficulties during this installation. 
Please make sure you have the diagnostic or log files ready before you contact 
technical support. 

Edwards 
8985 Town Center Parkway 
Bradenton, FL 34202 

T +1 800 655 4497 
F +1 866 226 2126 
E est.techsupport@fs.utc.com 
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2. What’s new in 3-SDU version 4.01 
3-SDU version 4.01 includes the features in all previously released versions, with 
the addition of the following new features: 

• Support for SIGA2 sensors and modules 

• Renaming of Australian marketplace to Australian AS4428 

• New marketplaces for Arabic Local and Proprietary, Australian AS7240, 
China Local and Proprietary, New Zealand, and Singapore 

• Arabic language support (limited to those shown in “4.1 Arabic language 
supported characters” on page 8) 

• 3-SDU context-sensitive Help 

• Merge of versions 3.83 (China release), 3.82 (China release), 3.80 
(Singapore release), and 3.90 (SIGA2) 

• Performance and quality resolutions and enhancements 

• Support for Windows 7, and 32-bit or 64-bit operating systems 

2.1 Support for all SIGA2 sensors and modules 

• Each CO sensor can be programmed as one of three new device types: 
COAlarm, COMonitor, or COSupervisory. 

• Each CO sensor can be commanded to accelerate its detection time, for 
testing purposes. 

• SIGA2-PHS detectors can report separately when their photo and heat 
elements activate, or report when either element activates like traditional 
SIGA-PHS detectors. 

• The photo element of the PHS detector can be bypassed for maintenance 
and testing. 

• The term “Alternate Sensitivity” is changed to “Alternate Sensing.” Alternate 
Sensing includes all Alternate Sensitivity features with the addition of PHS 
Alternate Operations. Note: Existing rules that use “Alternate Sensitivity” will 
still work. 

• Sensor responses are now configured using personality codes. 

• The new SIGA-TCDR Temporal Pattern Generator module generates sound 
patterns for carbon monoxide (CO) and fire alarm signals based on the type 
of sensor activation. Note: Requires the SIGA-AB4GT sounder base. 

• End of Life reporting is available for CO sensors. 

• The SIGx- prefix on sensors and modules has been removed. 
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2.2 New marketplaces 

3-SDU Version 4.01 includes all of the following marketplaces. Previously, these 
were distributed only in customized releases.  

• Singapore marketplace addition, released in 3-SDU 03.80.00 for Singapore 
only 

• China marketplace addition, released in 3-SDU 03.82.00 and 3-SDU 
03.83.00, supports marketplace requirements and language fonts 

• Australian marketplace, renamed to Australian AS4228, supports existing 
EST3 marketplace requirements in Australia 

• Australian marketplace AS4270, for existing EST3 with Edward Analog 
support using Ziton and European sensors and modules (EN 54) 

• New Zealand marketplace, for existing EST3 with Edward Analog support 
using Ziton and European sensors and modules (UL) 

2.3 Renaming of Australian marketplace 

3-SDU Release 4.01 renames the Australian marketplace to Australian AS4428.  

2.4 Arabic language support 

The Arabic marketplace addition supports a new language font and screen 
layouts for the Arabic marketplace. Only the 3-LCDXL and 3-LCDXL1 are 
supported. 

2.5 SDU Help 

3-SDU version 4.01 provides SIGA2 Help topics, and implements context-
sensitive Help (pressing the F1 key displays a Help topic that corresponds to the 
location and task being performed within the SDU).  

SDU Help requires that you have Internet Explorer 6 or later installed. The 
compiled HTML Help file is not compatible with other Web browsers.  

2.6 Merge previous versions 

Version 4.01 merges the following previous versions that were released for 
specific marketplaces: 3.83, 3.82, 3.80, and 3.74. All of the features and 
functions contained in these previous releases are carried forward into the single 
release of 3-SDU V4.01, regardless of marketplace.  

Note: Some features designed for a specific marketplace are not available in 
other marketplaces. Some features originally available only in individual 
marketplaces have been added to V4.01 for use in all marketplaces. 

The following sections list, for your convenience, the content of the previous 
releases of the 3-SDU that are combined in V4.01. 
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2.6.1 Previously released in version 3.83 (China marketplace) 

SDU version 3.83 added the following new features: 

• China Local and Proprietary marketplaces 

• Interlock and Interlockfeedback device types 

• 3-LCDXL1C and display layout 

• AC power monitored by setting 

• Cabinet Log to History filters 

• Master Cabinet setting upgrade 

In order to use these features, you must set the Market Place option on the 
Project Parameters > Operations tab for China Local or China Prop and install 
the following hardware: 

• 3-LCDXL1C Main LCD Display 

• SIGA-CC1 Single Input Signal 
Module 

• SIGA-CC2 Dual Input Signal 
Module 

• SIGA-MCC1 Single Input Signal 
Module 

• SIGA-CT1 Single Input Module 

• SIGA-IO Input/Output module 

• SIGA-HRSI(C) Class A2R Heat 
Detector 

• SIGA-PS(IC) Photoelectric Smoke 
Detector 

 • 3-SSDC1C, 3-SDDC1C, and 3-
DSDC1C Signature Loop Controller 
with 3-SDC1C card 

• 3-12/S2R Control/LED Display 

• 3-6/3S2RY Control/LED Display 

• 3-PPS/M-230C Primary Power 
Supply 

• 3-BPS/M-230 Booster Power 
Supply 

• 3-BBC/M-230 Booster Power 
Supply 

2.6.2 Previously released in version 3.82 (China marketplace) 

SDU version 3.82 added the following features: 

• Battery Depleted signal 

• User timeout 

• Scrolling speed 

• Steady Alarm LED enabled 

• Cabinet Port Restorations History filter 
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2.6.3 Previously released in version 3.80 (Singapore marketplace) 

SDU version 3.80 added the following features: 

• New marketplace for Singapore 

• Allow Disables only in Singapore marketplace 

• New CMS Supervised and Non-Supervised device types only in Singapore 
marketplace  

2.6.4 Previously released in version 3.74 (all marketplaces except China and 
Singapore) 

SDU version 3.74 added the following new features: 

• Removed check-in groups and emergency devices from 3-SDU 

• Increased the number of MODCOM and MODCOMP allowed in a project to 
60 

• Increased the number of AND groups allowed in a project to 999 

• Added the ability to scroll the annunciator configuration screen grid and save 
the form position  

 •  Removed relay sounder base groups from the BuildingReport.com report 

 • Added the 3 Switch/4 LED x 4 - (3-4/3SGYWR) device 

 •  Removed the restriction on duplicate serial numbers in a project 

• Changed the initial default setting for K5 on RZB12-6/3 

2.7 Performance enhancements and quality resolutions 

Version 4.01 supports new features and equipment (SIGA2) and includes 
performance and quality improvements.  

•  Audio channel and message labeling is restricted to allowable text lengths. 

•  When adding a 3-LCDXL or 3-LCDXL1 to an existing project, location text is 
reduced to fit on the 80-character display. A warning message now displays 
when adding a 3-LCDXL or 3-LCDXL1 to an existing project. 

3. Operating system compatibility 
3-SDU V4.01 is compatible with the Microsoft Windows 2000, Windows XP, 
Windows Vista, and Windows 7 operating systems.  

Version 4.01 can be installed on 32-bit or 64-bit operating systems. Note: The 
Version 4.01 installer does not support a Windows uninstall. If you need to 
uninstall V4.01, you will have to manually remove the installed files and 
directories. 
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The installer must select either the 32-bit or 64-bit HASP when prompted. 

4. Language support 
The following table details the language support available in SDU V 4.01. 

Table 2: Language support 
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Arabic [1] 
 

      
    X 

Chinese 
(Simplified PRC) 

   X   X 
 

X 
  

Chinese 
(Traditional Taiwan) 

   X   
     

Dutch 
(Standard - Netherlands) 

  X    
     

English 
(Australia) 

     X 
     

English  
(Britain) 

  X    
     

English 
(USA) 

X X X X X X X X X X X 

Finnish 
(Finland) 

  X    
     

French 
(Canada) 

X X     
     

German  

(Standard - Germany) 
  X    

     

Hebrew 
(Israel) 

X    X  
     

Italian 
(Italy) 

X  X    
     

Korean  
(Extended Wansung - 
Korea) 

   X   
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Polish 
(Poland) 

  X    
     

Portuguese 
(Brazil) 

X      
     

Portuguese 
(Standard - Portugal) 

  X    
     

Russian 
(Russia) 

X  X    
     

Slovak 
(Slovakia) 

  X    
     

Spanish 
(Mexico) 

X      
     

Spanish 
(Modern Sort - Spain) 

  X    
     

Turkish 
(Turkey) 

X  X    
     

 

[1] The specific Arabic characters supported are shown in Table 3 below. 

Note: KPDISP provides a single layout for use in the markets and languages 
served by the American, Middle East, and Australian marketplaces. 

4.1 Arabic language supported characters 

Table 3 is a complete list of supported Arabic characters. (All standard 
characters between 32 and 126 in Windows Code Page 1256 are supported.) 

Table 3: Supported Arabic language characters 

Contextual Forms Windows 

1256 Code 

DOS 

864 Code Isolated Final Medial Initial 

Name 

 hamza - - - ء 193 193

 alef madda above - -  آ  آ 162 ,194 194

 alef hamza above - - أ أ 165 ,195 195

 waw hamza - - ؤ ؤ 196 ,196 196
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Contextual Forms Windows 

1256 Code 

DOS 

864 Code Isolated Final Medial Initial 

Name 

 alef hamza below - - إ إ 168 ,199 197

 yeh hamza ئ ئ ئ ئ 198 ,198 ,245 ,233 198

 alef - -  ا  ا 168 ,199 199

 beh  ب  ب  ب  ب 169,169,200,200 200

 teh marbuta - -  ة  ة 201 ,201 201

 teh  ت  ت ت ت 202 ,202 ,170 ,170 202

 theh  ث  ث ث ث 203 ,203 ,171 ,171 203

 jeem  ج  ج   ج  ج 204 ,204 ,173 ,173 204

 hah  ح  ح  ح  ح 205 ,205 ,174 ,174 205

 khah  خ  خ  خ    خ 206 ,206 ,175 ,175 206

 dal - -  د  د 207 ,207 207

 thal - -  ذ  ذ 208 ,208 208

 reh - -  ر  ر 209 ,209 209

 zain - -  ز  ز 210 ,210 210

 seen  س  س  س  س 211 ,211 ,188 ,188 211

 sheen  ش  ش  ش  ش 212 ,212 ,189 ,189 212

 sad  ص  ص  ص  ص 213 ,213 ,190 ,190 213

 dad  ض  ض  ض  ض 214 ,214 ,235 ,235 214

 tah  ط  ط  ط  ط 215 ,215 ,215 ,215 216

 zah  ظ  ظ  ظ  ظ 216 ,216 ,216 ,216 217

 ain  ع  ع  ع  ع 217 ,236 ,197 ,223 218

 ghain  غ  غ  غ  غ 218 ,247 ,237 ,238 219
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Contextual Forms Windows 

1256 Code 

DOS 

864 Code Isolated Final Medial Initial 

Name 

220 224,224  -  - tatweel 

 feh  ف  ف  ف  ف 225 ,225 ,186 ,186 221

 qaf  ق  ق  ق  ق 226 ,226 ,248 ,248 222

 kaf  ك  ك  ك  ك 227 ,227 ,252 ,252 223

 lam  ل  ل  ل  ل 228 ,228 ,251 ,251 225

 meem  م  م  م  م 229 ,229 ,239 ,239 227

 noon  ن  ن  ن  ن 230 ,230 ,242 ,242 228

 heh  ه  ه  ه  ه 231 ,244 ,243 ,243 229

 waw - -  و  و 232 ,232 230

 alef maksura  ي   ي  ی  ی 234 ,234 ,245 ,233 236

 yeh ي  ي  ي  ي 234 ,234 ,246 ,253 237

 lam alef - -  لا لا  158 ,157 199 + 225

 Lam alef with madda - - لآ لآ 250 ,249 194 + 225
above 

 Lam alef with hamza - - لأ لأ 154 ,153 195 + 225
above 

 لإ لإ 158 ,157 197 + 225
- - Lam alef with hamza 

below 

145 39    ‘    Left single quotation 
mark 

146 39    ’    Right single quotation 
mark 

161 172    ‘    Arabic comma 

 Arabic semicolon    ؛    187 186

 Arabic question mark    ؟    191 191

215 222    ×    Multiplication sign 

247 221    ÷    Division sign 
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4.2 Bilingual language character sets 

When primary and secondary languages are selected, both languages must be 
supported in the same font table. 

Table 3: Bilingual character sets 

EST3 code page Bilingual language sets 

1250 (Eastern Europe) Croatian, Czech, English, Hungarian, Polish, Slovak 

1251 (Cyrillic) English, Russian 

1252 (Western Europe) Danish, Dutch, English, Finnish, French, German, Italian, 
Norwegian, Portuguese, Spanish, Swedish 

1254 (Turkish) English, Turkish 

1255 (Hebrew) English, Hebrew 

 

4.3 Printer code pages 

The following table shows the DOS Code Page support required to print in the 
local language. Since not all Windows characters are available on the DOS 
printer, some characters may not be supported. 

Table 4: Printer code pages 

EST3 code page Printer code page 

936 (Chinese Simplified) Windows Code Page 936 (GB) 

949 (Korean) Windows Code Page 949 (Extended Wansung) 

950 (Chinese Traditional ) Windows Code Page 950 (Big 5) 

1250 (Eastern Europe) DOS Code Page 852 

1251 (Cyrillic) DOS Code Page 866 

1252 (Western Europe)  DOS Code Page 850 

1254 (Turkish) DOS Code Page 857 

1255 (Hebrew) DOS Code Page 862 

1256 (Arabic UL) DOS Code Page 864 
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5. Software versions and compatibility 

5.1 LRM compatible versions 

You must upgrade all applicable microcode versions to take full advantage of the 
new features offered in 3-SDU V4.01. 

Table 6: 3-SDU version 4.01 software compatibility 

LRM Oldest 
version * 

Shipping 
version 

Medium Part 
number 

3-ASU 1.4 3.4 CD 3-SDU 

3-AADC 1.4 3.41 CD 3-SDU 

3-AADC1 1.4 3.71 CD 3-SDU 

3-CPUx 1.33 3.70 CD 3-SDU 

3-EASC 3.4 3.6 CD 3-SDU 

3-EADC 3.4 3.6 CD 3-SDU 

3-FTCU 1.0 1.2 Chip 190156 

3-FTCU 1.4 3.4 Chip 190254 

3-IDC8/4 1.1 3.6 Chip 190159 

3-LDSM 1.0 3.0 Chip 190153 

3-MODCOM(P) 3.0 3.6 CD 3-SDU 

3-OPS 1.0 3.0 Chip 190158 

3-PPS 1.0 3.61 Chip 190157 

3-BPS 1.0 3.61 Chip 190157 

3-BBC 3.0 3.6 Chip 190157 

3-RS485-A/B  1.5 PAL Chip 190271 

3-RS485-R     

3-SSDC 1.52 3.32 CD 3-SDU 

3-SDDC 2.1 3.32 CD 3-SDU 

3-SSDC1 1.52 3.7 CD 3-SDU 

3-SDDC1 2.1 3.7 CD 3-SDU 

3-SAC 3.1 3.6 CD 3-SDU 

3-ZA15 1.1** N/A Chip 190151 

 1.3 N/A PAL Chip 190191 

3-ZA20A 1.4 3.61 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA20B 1.4 3.61 Chip 190252 
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LRM Oldest 
version * 

Shipping 
version 

Medium Part 
number 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA30 1.1** N/A Chip 190151 

 1.3 N/A PAL Chip 190191 

3-ZA40A 1.4 3.61 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA40B 1.4 3.61 Chip 190252 

 1.4 1.4 PAL Chip 190191 

 1.0 1.0 PAL Chip 7400068 

3-ZA90 1.4 3.61 Chip 190252 

 1.4 1.4 PAL Chip 190191 

3-ZA95 1.4 3.61 Chip 190252 

 1.0 1.0 PAL Chip 7400068 

CRC 1.3 1.7 CD 3-SDU 

KPDISP 1.0 1.6 CD 3-SDU 

CDR-3 2.0 3.5 Chip 190071 

*Oldest version still compatible with the current version of 3-SDU 

**Version 1.12 required for stand-alone mode disabled feature. To obtain V1.12, request a 
deviation version for part number 190151 from Technical Support. 

Notes 

• 3-CPUx V4.0 microcode cannot reside on the same network as earlier  
3-CPUx microcode. To use 3-SDU V4.01, all panels must be upgraded to 
V4.0. Networks with 3-CPU microcode version 1.4 or later can be upgraded 
with the 3-SDU by using the network download function. See “8. Upgrading 
microcode versions to 4.0” on page 18. 

• The 3-CPU3 is 100 percent backward compatible with, and can be installed 
on the same network as, 3-CPU1 and 3-CPU. The 3-CPU3 and 3-CPU1 
require at least version 1.41 microcode. 

• 3-FTCU firmware comes in two noninterchangeable forms. Part 190254 
cannot be used to update Part 190156, and vice versa. 
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5.2 3-SDU database compatibility 

Use 3-SDU V4.01 to generate databases for the LRMs listed in Table 6. 

Table 7: LRM microcode supported by 3-SDU V4.01 

LRM 3-SDU supported microcode versions 

3-AADC V1.4, V3.0, V3.1, V3.41 

3-AADC1 V1.4, V3.0, V3.1, V3.41, V3.6, V3.7, V3.71 

3-ASU V1.4, V3.0, V3.1, V3.4 

3-CPU V1.41, V1.52, V2.0, V3.0, V3.1, V3.2, V3.41, V3.5, V3.6, V3.7, V3.80, 
V3.82, V3.83, V4.0 

3-EADC/EADC V3.4, V3.6, V4.0 

3-MODCOM(P) V3.0, V3.1, V3.11, V3.12, V3.6 

3-SAC V3.1, V3.5, V3.6 

3-SSDC/SDDC V1.52, V2.1, V3.32 

3-SSDC1/SDDC1 V1.52, V2.1, V3.32, V3.6, V3.7, V3.71, V3.83, V4.0 

CRC V1.3, V1.4, V1.5, V1.6, V1.7 

KPDISP V1.0, V1.1, V1.2, V1.3, V1.4, V1.5, V1.6 

 

5.3 Latest compatible versions 

The following table identifies the most recent version of LRM microcode that is 
compatible with each version of 3-CPU microcode. We recommend that you use 
the latest compatible version of LRM microcode. 

Table 8: LRM and 3-CPU microcode compatibility 

3-CPU microcode versions 

LRMs V1.52 V2.0 V3.0 V3.1 V3.2 V3.41 V3.5 V3.6 V3.7 V3.80 V3.82 V3.83 V4.0 

3-AADC V1.4 V2.1 V2.1 V3.1 V3.1 V3.41 V3.41 V3.41 V3.41 V3.41 V3.41 V3.41 V3.41

3-AADC1 V1.4 V2.1 V2.1 V3.1 V3.1 V3.41 V3.41 V3.6 V3.7 V3.7 V3.71 V3.71 V3.71

3-ASU V1.4 V3.4 V3.4 V3.4 V3.4 V3.4 V3.4 V3.4 V3.4 V3.4 V3.4 V3.4 V3.4 

3-EASC --- --- --- --- --- V3.4 V3.4 V3.6 V3.6 V3.6 V3.6 V3.6 V4.0 

3-EADC --- --- --- --- --- V3.4 V3.4 V3.6 V3.6 V3.6 V3.6 V3.6 V4.0 

MODCOM 
(P) 

--- --- V3.0 V3.12 V3.12 V3.12 V3.12 V3.6 V3.6 V3.6 V3.6 V3.6 V3.6 

3-SAC --- --- --- V3.4 V3.5 V3.5 V3.5 V3.6 V3.6 V3.6 V3.6 V3.6 V3.6 

3-SSDC V1.52 V2.1 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32

3-SDDC V1.52 V2.1 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32 V3.32

3-SSDC1 V1.52 V2.1 V3.32 V3.32 V3.32 V3.6 V3.6 V3.6 V3.7 V3.7 V3.82 V3.83 V4.0 
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3-CPU microcode versions 

LRMs V1.52 V2.0 V3.0 V3.1 V3.2 V3.41 V3.5 V3.6 V3.7 V3.80 V3.82 V3.83 V4.0 

3-SDDC1 V1.52 V2.1 V3.32 V3.32 V3.32 V3.6 V3.6 V3.6 V3.7 V3.7 V3.82 V3.83 V4.0 

CRC --- --- --- V1.4 V1.4 V1.4 V1.6 V1.7 V1.7 V1.7 V1.7 V1.7 V1.7 

KPDISP --- --- --- V1.4 V1.4 V1.4 V1.5 V1.6 V1.6 V1.6 V1.6 V1.6 V1.6 

6. Version 4.0 microcode updates 
3-SDU V4.01 includes the following microcode updates: 

• 3-CPUx microcode, version 4.0 

• 3-SxDC1 microcode, version 4.0 

• 3-EAxC microcode, version 4.0 

Microcode 4.0 versions include all previous version features. 

6.1 3-CPUx version 4.0 microcode 

• Added support for SIGA2 sensors and modules 

• Added or merged support for all marketplaces 

• Added or merged language support for all marketplaces 

6.2 3-SxDC1 version 4.0 microcode 

• Added support for the SIGA2 sensors and modules. 

Corrections 

• Versions 3.4 and 3.5 of the 3-SSDC1 application code had an issue with 
alarm verification: when a device was in verification, and then reached the 
alarm threshold, the loop controller may have rebooted. Upgrade all projects 
that use alarm verification to this new version of 3-SSDC1 application code. 

6.3 3-EAxC V4.0 microcode 

• Added and updated support for the European, New Zealand, and Australia 
AS7240 marketplaces. 

6.4 Previous microcode versions 

The following table shows the contents of previous microcode versions, for your 
convenience. 
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Table 9: Microcode versions previous to 4.0 

LRM Version Change Contents 

Enhancements • Added new UI layout and language. 

• Relabeled Bins. 

• Added support for Master Cabinet. 

• Added ACFail event type and the monitoring of 
AC Power Failure on remote power supplies. 

• Added support for Interlock and 
Interlockfeedback devices. 

• Added support for Interlockfeedback failure 
event. 

3.83 

Corrections • Previous versions had problems with the 
execution of partition reset from a command list 
in a network configuration, which has been 
corrected in this release. 

• Previously the Level 4 password could not be 
modified in the European marketplace. This has 
been corrected. 

• Previously the 3-MODCOM(P) would transmit a 
normal test message while the LRM was 
disabled. This has been corrected so that it 
transmits an abnormal test message. 

• In V3.5 the EST3 could, under some conditions, 
send a Gateway status indicating that there 
were no panels communicating on the network. 
This has been corrected so that the status 
message always indicates that at least the local 
panel is communicating. 

• The FirstDisable message is not displayed in 
the Trouble queue in the European 
marketplace. 

• Gateway communications has been updated to 
handle long latency LAN connections in a more 
robust manner. Previously, under some 
conditions, it was possible for gateway 
commands to be lost. 

3.82 Enhancement • Added new UI layout and language.   

3.80 Enhancements • Added support for allowing disablement. 

• Added CMSSupervisoryoutput and 
CMSNonSupervisoryoutput device types. 

3-CPUx 

3.70 Enhancement • Addressed AC Failure and Reset Partition. 

3-EAxC 3.6 Correction • New version prevented noise from activating 
stand-alone alarm devices. 
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LRM Version Change Contents 

3-MODCOM(P 3.6 Correction • Updated the Contact ID protocol timing to 
resolve compatibility issues seen with the  
Sur-Guard SGDRL2A receiver. 

3-SAC 3.6 Enhancement • Added support for message annunciation 
routing. 

CRCx 1.7 Enhancements • Addressed a previous issue whereby loose 
fitting doors or door sensors relocked 
immediately upon being unlocked. CRCs can in 
this release be set to remain unlocked for a 
specific period of time before relocking. The 
programming of this feature requires  
ACDB(-KE) V1.4. 

• The number of consecutive access-denied-
unknown user reads from the card readers 
before the reader is disabled is programmable 
in this release. The amount of time before the 
reader is re-enabled once a reader disable is 
active is also programmable. The programming 
of this feature requires ACDB(-KE) V1.4. 

KPDISP 1.6 Enhancements • Added support for message annunciation 
routing. 

• Added the ACFail event type and the 
monitoring of AC Power Failure on remote 
power supplies. 

3-IDC8/4 3.6 Correction • Stand-alone alarm can no longer be triggered 
by an active Supervisory circuit. 

3-PPS/BPS/BBC 
firmware 

3.6 Corrections • Previously, intermittent Pwr_Supply_Fail 
ppcc0617 faults could be generated under light 
supervisory load conditions. This has been 
corrected in this release. 

• The AC_Brownout ppcc0614 fault is now of 
type ACFAIL. Rules referencing this device will 
need to be updated. 

• Corrected Power Supply from posting a false 
“Rail Voltage Out of Spec” trouble. 

• Rail Voltage Below Battery Voltage is detected 
in this release. 

 

7. Installing and upgrading to 3-SDU V4.01 
We recommend that you do not manually delete your previous version of the  
3-SDU. Rather, let the installation program update that version to the current 
version. 
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The 3-SDU runs best on a computer with a resolution of 1024 x 768 (or better) 
and small fonts. If any other settings are used, the system will resize some of the 
dialog boxes. 

Install only one version of the 3-SDU on your PC. 

7.1 Running the 3-SDU 

Remember to install your security key in your computer's parallel (LPT1) or USB 
port. Any other devices that share this port must be plugged into the key. 

Save your project periodically as you are working on it. Export your project to 
backup storage media on a regular basis to protect your work. 

7.2 ECP gateway port selection 

See the external equipment manufacturer's documentation for a compatible ECP 
gateway selection. 

If an ECP port is configured on the 3-CPUx, then 38.4 Kbaud is not supported for 
download via the auxiliary ports to the 3-CPUx. However 19.2 Kbaud is 
supported. 

If an ECP gateway port is not configured on the 3-CPU, then 19.2 Kbaud is not 
supported for download via the auxiliary ports to the 3-CPUx; 38.4 Kbaud is 
instead supported. The RJ-11 connector always supports 19.2 Kbaud and  
38.4 Kbaud for downloading. 

8. Upgrading microcode versions to 4.0  

8.1. 3-CPUx version 4.0 

The new application and bootloader code must both be downloaded to all panels 
in the system. 

Project version numbers are embedded in each project file. Because the Save As 
command creates a new version number that is different than the embedded 
version, you must use the following procedure to install V4.0. Please follow these 
steps in the correct order to upgrade the hardware and software in your system. 

Note: Do not mix different versions of 3-CPUx microcode on the same network. 
Upgrade an existing system by carefully following one of the two procedures that 
follow, depending on whether your current software version number is earlier or 
later than V1.33.  

To upgrade V1.33 or earlier to V4.0: 

1. Install 3-SDU version 4.01. 

2. Choose File > Open and select your project from the Open Project dialog box. 
Click OK to open the project. 
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3. Click OK to upgrade the microcode of your project. 

4. Save your project as a new version, using the Save As command on the File 
menu. 

5. Choose Rules > Compile to recompile your project. 

6. Choose Tools > DB Conversion > All Databases to create databases for the 
loop controllers and cabinets. 

7. Choose File > Save to save the recompiled project. 

8. Disconnect the network wiring at all panels. 

9. Choose Tools > Communications and select Single Step for the Download 
mode. 

10. From the LRM Type Display Filter group, select 3-CPU. From the File Display 
Filter group, select Application Code and Bootloader code. (Do not include 
the 3-SSDC/3-SDDC database, code, or bootstrap.) 

11. Connect the laptop to a node CPU, click Download, and then click Start to 
download the code. 

12. From the File Display Filter group, select Database. Click Download, and then 
click Start to download the code. 

13. Connect the laptop directly to the loop controller and the 3-ASU to download 
the application and bootstrap code. 

14. Select database and download as required. 

15. After all nodes are upgraded, reconnect the network wiring to all panels. 

16. Using the Command Menu, restart the system. 

To upgrade V1.4 or later to V4.0: 

1. Install 3-SDU version 4.01. 

2. Choose File > Open and select your project from the Open Project dialog box. 
Click OK to open the project. 

3. Click OK to upgrade the microcode of your project. 

4. Save your project as a new version, using the Save As command on the File 
menu. 

5. Choose Rules > Compile to recompile your project. 

6. Choose Tools > DB Conversion > All Databases to create databases for the 
loop controllers and cabinets. 

7. Choose File > Save to save the recompiled project. 

8. Choose Tools > Communications and select Network for the Download mode. 
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9. From the LRM Type Display Filter group, select 3-CPU. From the File Display 
Filter group, select Database. (Do not select the Application Code, Bootloader 
Code, or any 3-SSDC/3-SDDC options.) 

10. Connect your laptop to the first CPU in the network (any node for Class A 
networks), click Download, and then click Start to download version 4.0 of the 
database. 

11. From the LRM Type Display Filter group, select 3-CPU. From the File Display 
Filter group, select Application Code. (Do not select the Database, Bootloader 
Code, or any 3-SSDC/3-SDDC options.) 

12. Click Download, and then click Start to network download version 4.0 of the 
application code to all nodes. 

13. From the LRM Type Display Filter group, select 3-CPU. From the File Display 
Filter group, select Bootloader Code. (Do not select the Database, 

Application Code, or any 3-SSDC/3-SDDC options.) 

14. Click Download and Start to network download version 4.0 bootloader code to 
all nodes. 

8.2 Upgrading firmware on 3-DSDC(1)(C), 3-SDDC(1)(C), and 3-AADC(1) 
loop controllers 

You must upgrade the 3-CPUxs before upgrading the loop controllers. 

You can upgrade the loop controllers using network downloads. 

If the bootstrap download fails, or if the steps are performed out of order, you 
must cycle the power on the panel and restart the upgrade by downloading the 
bootstrap code again. 

You must complete each of the following steps in separate download sessions. 

To upgrade the loop controllers: 

1. Download the 3-SSDC/3-SDDC/3-AADC bootstrap to each LRM. (Download 
the bootstrap only; do not download the application code or database.) 

2. From the front panel display, issue a restart command for all panels. 

3. Download the 3-SSDC/3-SDDC/3-AADC application code. 

4. Download the 3-SSDC/3-SDDC/3-AADC loop controller databases. 

8.3 Upgrading the 3-ASU 

When upgrading the 3-ASU, we recommended that you do so in the following 
order:  

1. Download the boot code. 

2. Download the application code. 
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3. Download the database. 

8.4 Upgrading the CRC 

When upgrading the CRC/CRCXM, we recommend that you do so in the 
following order:  

1. Download the SDU application code. 

2. Download the SDU database. 

3. Download the ACDB database (from the CRC Administration tab, select the 
Destination DB Init task). 

9. Known issues 
The following known issues exist for 3-SDU version 4.01.  

9.1 Windows 7 

To install on a machine running Windows 7, administrator rights must be used. 
Run setup.exe by right-clicking and choosing “Run as Administrator.” 

9.2 Calibrate command 

The Calibrate command for EA series devices has a maximum adjustment of 
40% dirty. When calibrating a device that has been cleaned or is new, perform 
the Calibrate command several times in succession, waiting 20 seconds between 
each calibration. 

9.3 3-ASU 

If you receive a Code 33 Error when downloading the database to the 3-ASU, 
you must reduce the message file size or the quantity of messages. 

9.4 Duplicate label text error with unconfigured cabinets 

If you try to run a Rules Compile with a project that contains more than ten 
unconfigured cabinets, the SDU can generate a “duplicate Label Text” error 
message. If this occurs, go to the Cabinet Configuration dialog box and select 
the cabinet with the error. Click on the Modules tab, and then close the Cabinet 
Configuration dialog box and attempt to rerun the Rules Compile.  

9.5 Loop controller communications error message 

The SDU displays error code 0x35, shown in Figure 1, when downloading 
application code to a loop controller that has incompatible boot code.  

Verify that the loop controller has boot code compatible with 3-SDU V4.01. For 
more information, see “5. Software versions and compatibility” on page 12 and 
“8. Upgrading microcode versions to 4.0” on page 18. 
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Figure 1: Loop controller communications error message 

 

9.6 Compatibility with FireWorks version 1.60.01 and earlier  

FireWorks versions 1.60.01 and earlier have a compatibility issue with 3-SDU 
version 4.01, regarding data imported from CO devices and split configuration 
modes on SIGA2 model detectors only. Since FireWorks does not recognize the 
CO devices or elements in a split configuration, it reports “undefined errors” for 
those devices/elements. Note: Split configurations are selected in the Operations 
option on the Signature Series Configuration – Detectors tab.  

The device/element activation produces the following results: 

• SIGA2-HCOS activations import as a normal Heat detector activation. CO 
activations import as undefined errors. 

• SIGA2-PHCOS activations import as a normal Photo detector activation. CO 
activations import as undefined errors. 

• SIGA2-PCOS activations import as a normal Photo detector activation. CO 
activations and supervisory activations import as undefined errors. 

• SIGA2-PHS activations import as a normal Photo detector activation. If the 
device is configured as anything other than ‘Photo/Heat is Alarm’ activations 
import as undefined errors. 

• SIGA2-COS activations import as undefined errors. 

You can verify the data in your import file from the SDU Import window. Click the 
Verify OXP File button to view data in the OXP file that FireWorks cannot 
understand.  See Figure 2. 
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Figure 2: SDU Import errors (types 141 and 142) 

 

When the import finishes, FireWorks lists the devices that it could not 
define.  See Figure 3. 

Figure 3: SDU Import undefined device messages  

 

Since FireWorks cannot understand these devices, it does not include them in 
the System Builder tree. Therefore, the device list may no longer be numbered 
logically. See Figure 4. 
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Figure 4: System Builder sequence interruption due to unrecognized devices/elements 

 

When one of these devices activates, FireWorks annunciates the event as 
“undefined” in the System Control window. The messages appear in red in the 
Event Action and Event List Action panes, are similar to an alarm event, and 
identify the event as “undefined alarm” or “undefined error.” 

9.7 SDU mapping issue  

When uploading a Signature loop map, any SIGA2-PCOS configured with 
Personality 51 will always show a map mismatch and be in RED. When looking 
at the Actual vs. Expected screen, the “CO Setting” will show “N/A” on the Actual 
side, while the Expected side will display “COAlarm” or “COSupervisory”. If you 
choose to Accept Actual, the SDU will set the CO Setting to its default value 
(COSupervisory). Even though these devices show a map mismatch when the 
Signature Loop Map is uploaded, the EST3 System will not post a map fault 
trouble. 


