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Introduction
Welcome to EPIDesigner 6.3, the professional-quality design software that makes 
creating superb, full-color photo badge templates quick and easy. As well, create 
report templates that include photos and text drawn from your database or appli-
cation. Import eye-catching graphics as card backgrounds and personalize your 
designs with the logo of your organization. Link templates to cardholder infor-
mation and images stored in your database. Add bar codes, or encode magnetic 
stripes and smart chips, all within the same application. Even if you’re not a 
design professional, you’ll get picture-perfect results in minutes with EPIDesigner.

First-Time Computer Users

The first step on the road to designing identification cards is to learn how to 
configure and use this software. This User’s Guide was written to guide you 
through the entire process of configuring your EPIDesigner workspace, linking to 
your database, and designing cards. The procedures outlined in this guide are 
straightforward, step-by-step instructions that even first-time computer users will 
be able to follow.

If you are uninitiated in the use of computers in general, do not be intimidated by 
some of the terminology used in this guide. These terms are common throughout 
the computer and photo imaging industries. We have included an extensive 
glossary at the back of this guide to introduce you to the terms that are associated 
with using EPIDesigner and digital imaging. This same glossary, and most of 
these instructions—as well as extensive reference material—are also available on-
line, through the Help menu. Please make ample use of these tools.

Conventions

This guide and the EPIDesigner Help system use the following conventions for 
menus and shortcuts:

Example Descr ibes

Choose  F i le  >  Page  Setup
Choosing the Page  Setup comm and 
in  the F i le  menu.

Ctr l  +  n
Ho ld ing down Contro l  and press ing 
the  lowercase  let t er  ‘n’.

C t r l  +  Sh i f t  +  n
Ho ld ing down Contro l  and Sh i f t ,  and 
press ing the let t er  ‘n’.

R ight-cl ick Cl ick ing the r ight  m ouse butt on

Ctr l -c l ick Ho ld ing down Contro l  and c l ick ing 
the  lef t  mouse  butt on .
Introduction - First-Time Computer Users
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EPIDesigner Setup

What’s New in EPIDesigner

The following list outlines new features in version 6.3 of EPIDesigner:

• Select from new magnetic stripe character set options. You can choose ISO 
Standard, AAMVA Standard, or Custom.

• Open more than one EPIDesigner session at a time so you can easily cut and 
paste objects between designs.

• Select hidden objects placed under other objects in a layout.

• Customize the drop-down lists of colors in the toolbar and various Properties 
dialogs, and use these custom colors to maintain a consistent color scheme in 
each card layout (see “Creating Your Own Colors” on page 1.53).

• Align objects on a card layout by text baseline, even if the objects have different 
text fonts or sizes (see “Align and Distribute Objects” on page 1.32).

• Use the Print image exactly as is option to ensure objects are printed without 
being altered. This disables options to change the object’s line color and 
thickness, shadow, cropping, fading, transparency and grayscale, so that you can 
print bitmaps that contain digital watermarks (see “Change the Image 
Properties” on page 1.40).

• Select Don't clip image to print an entire image even if it is too large to fit on 
the card layout (see “Change the Image Properties” on page 1.40).

• Static image auto-sizing sets the size of an object to match the physical size of 
the image as specified in the image file header. This prevents EPIDesigner from 
re-sizing the image (see “Add Static Images” on page 1.40).

• New settings allow the designer to specify the width and height of an object. 
Using these measurements, and setting the object’s distance to the edge of the 
card, designers no longer need to manually calculate image coordinates using 
the left, right, top, and bottom positions of the object (see “Object Properties” on 
page 1.28).

• When cropping a background, click anywhere in the displayed image to choose 
a color to crop, or use RGB color match to specify an amount of variation from a 
selected color. You can also let EPIDesigner select the color automatically (see 
“Add Close-Cropping Effects” on page 1.42).

• Display text vertically (top to bottom) using the Vertical text option in the Static 
and Dynamic Text Properties dialogs (see “Adding Static and Dynamic Text” on 
EPIDesigner Setup - What’s New in EPIDesigner
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page 1.35).

• Use Show object outlines on the Rulers and Grid page to display an outline 
around every object on the layout (see “Setting the Workspace Options” on page 
1.12).

• Use the Image Setup command to define the types of dynamic images that are 
available from the database (see “Setting the Workspace Options” on page 1.12).

• Use Zoom In and Zoom Out to customize the view of the card layout (see 
“Setting the Workspace Options” on page 1.12).

• Set up EPIDesigner to automatically adjust the contrast of images (see 
“Enhancing the Card Background” on page 1.25).

• Print ICAO standard machine-readable passports and travel documents using 
two new expression functions (see “Other functions” on page 1.68).
Badge Designer Manual for Picture Perfect v4 and Secure Perfect v6
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The EPIDesigner Workspace
With EPIDesigner running, you will notice one or more bars located across the top 
of the workspace window, below the EPIDesigner menu bar. The various toolbars 
available at the top of the EPIDesigner workspace are movable and resizable. To 
do so, click on the vertical bar at the left end of the toolbar and drag it to the 
desired location.

Note: The toolbars that appear on the EPIDesigner workspace may vary 
according to the product you have purchased.

The Toolbar

The EPIDesigner toolbar is located directly below the menu bar. It provides quick 
mouse access to many of the commands found in the various EPIDesigner menus.

• New, Open, Save, Cut, Copy and Paste buttons: Perform commonly used 
Windows commands.

• Undo and Redo buttons: Allow you to reverse the previous actions, or redo 
them if you so choose.

• Flip Layout button: Allows you to toggle between the front and back view of 
the card.

• Zoom In and Zoom Out buttons: Allow you to change the view of the layout.
• Drawing Object buttons: Allow you to select design objects; draw shapes 

(lines, rectangles, round rectangles, ellipses); or place text objects, static 
images, dynamic images, and bar codes on your card template.

• Object Properties button: Allows you to enable or disable special design 
features, such as image “cameos” or conditional display settings for the 
highlighted object.

• Layout Properties button: Allows you to set global parameters for the 
currently open layout (such as page size and background image).

• Print button: Allows you to print the card template.
• Print Preview button: Displays the active card template design as it would 

appear when printed.
• About button: Displays support and licensing information for your copy of 

EPIDesigner.
The EPIDesigner Workspace - What’s New in EPIDesigner
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The Text Style Bar

The text style bar provides access to the visual properties of text objects.

• Font Face list: Allows you to select a font when creating static or dynamic text 
objects.

• Point Size list: Allows you to select the point size of the characters.
• Font Style buttons: Allow you to change the style of the selected font (bold, 

italic, underline).
• Horizontal Justification buttons: Allow you to horizontally left-justify, 

center, or right-justify your text objects (and some bar codes) within their 
bounding boxes (that is, the adjustable invisible box within which the text 
resides).

• Vertical Justification buttons: Allow you to vertically top-justify, center, or 
bottom-justify your text objects (and some bar codes) within their bounding 
boxes.

The Attributes Bar

The attributes bar provides quick mouse access to color and line weight settings, 
and access to data fields or expressions that are linked to dynamic text objects, bar 
codes, and image keylines.

• Line Attribute lists: Allow you to select the color and weight (thickness) of 
lines and borders around drawing, text and image objects. You can also select 
Border Text from the Line color list (Pro only).

• Fill Color list: Allows you to select the color for fills (solid colors that are 
used to “fill” shapes).

• Text Color list: Allows you to select the color for text.
• Data Field list: Allows you to link dynamic text objects, bar codes, and image 

keylines to data fields or expressions. For example, linking a dynamic text 
object to the First_Name field in the database results in “First_Name” 
appearing on the card design (in whatever font and size you select). This is 
replaced by the cardholder’s first name (in your specified font and size) when 
the ID card is printed.

Align HorizontallyFont Face Point Size

Bold

Italic

Underline Align Vertically

Line Color

Line Weight

Fill Color

Text Color

Data Field
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The EPIDesigner Design Window

The Design Window area of the EPIDesigner workspace is where you design card 
templates. When a new file is created, EPIDesigner opens a Design Window for 
the front of the card layout. The back of the card can be viewed at any time by 
selecting the View menu, and clicking Show Back of Layout, or by clicking Flip 
Layout on the toolbar. 

Figure 1  EPIDesigner Design Windows

Setting Up EPIDesigner
You can tailor the EPIDesigner workspace to better suit your needs. To change the 
default options, on the View menu, click Options. The Options dialog box 
appears.

Figure 2  Options dialog box

A - Rulers. Available both horizontally 
and vertically for object alignment.

B - Grid. Used for object alignment. Can 
be hidden from the screen.

C - Extended cursor crosshairs. 

A

B

C

The EPIDesigner Workspace - Setting Up EPIDesigner
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Specifying Undo Levels

Undo levels refer to the number of times that actions or commands can be 
reversed when you click Undo on the Edit menu. 

For example, if you draw a circle on a card design and then set the line color from 
black to red, these actions represent two levels that can be undone. Therefore, if 
you click Undo twice, the first use would revert the line color of the circle from 
red to black, and the second use would delete the circle.

If you undo too many levels of actions or commands, you can reverse the Undo by 
clicking Redo on the Edit menu.

To set up the Undo Levels, perform these steps:

1. On the View menu, click Options. The Options dialog box appears (see 
Figure 2).

2. Enter the number of undo levels in the Undo remembers the last XXX 
commands field. The maximum you can enter is 100 and the minimum is 1. 

Note: The higher the setting, the more memory EPIDesigner requires to 
operate.

3. Click OK, or proceed to the next section for more configuration.

Setting Background Image Compression

Select the Compress Background Images... option to have EPIDesigner 
compress background images to save space when your DNG files are saved (see 
Figure 2).

When you import a background image into a card design, EPIDesigner will 
perform two separate compressions of the file, using JPEG and TIFF LZW 
formats, and then select the smaller of the two files.

Clear this option to store your images without any form of compression. This 
guarantees that there will be no loss in image quality.

Setting the Workspace Options

Rulers To display the horizontal and vertical rulers on the design window, on the View 
menu, click Rulers. To modify the ruler settings, on the View menu, click 
Options, and then select the Rulers and Grid tab. Here you can set whether the 
rulers should appear in the measurement system set as your Windows default, or 
override that setting by choosing either Metric or Inches.
Badge Designer Manual for Picture Perfect v4 and Secure Perfect v6
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Grid Lines To display the editing grid, on the View menu, click Grid. To modify the grid 
options, on the View menu, click Options, and then select the Rulers and Grid 
tab. You can also use the Show Grid option on the Rulers and Grid tab to display 
the grid lines on the design area. Set the grid size by typing in a positive number 
between 0.02 and 1.0 (inches or their equivalent metric values) in the Grid 
Spacing fields, thus changing the distance between the lines. Select the Snap 
Objects to grid option to have the objects you move always line up along the grid 
lines.

Cursor Crosshairs You can display extended crosshairs from your mouse cursor to help you line up 
objects horizontally or vertically. To set up cursor crosshair, on the View menu, 
click Options, and then select the Rulers and Grid tab. Click Show Cursor 
Crosshair. See Figure 1 on page 11.

Zoom In/Out To enlarge or reduce the size of your card design workspace, on the View menu, 
click the Zoom In or Zoom Out button. This command affects only how you 
view your card on your computer monitor and does not affect how the card will 
print. The view you select will be displayed the next time you open the card.

Show Object Outlilne This option displays an outline around every object on the layout. To display 
object outlines, on the View menu, click Options, and then select the Rulers and 
Grid tab. Click Show object outlines. These outlines appear on the screen only 
and are not visible on the printed layout.

Image Setup This command allows you to define the types of dynamic images that are available 
in the database. On the View menu, click Image Setup. If EPIDesigner is 
connected to a database, the Image Setup configures the image types defined in 
that database.

Connecting to Other Databases

By default, EPIDesigner is not connected to a database. To connect to a database, 
you must first set up a properly configured JET database or ODBC data source for 
the new database (if one does not yet exist).

Use a Database with EPIDesigner

To use a database with EPIDesigner, perform these steps:

1. On the View menu, click Options. The Options dialog box appears (see Figure 
2). 
The EPIDesigner Workspace - Setting Up EPIDesigner



14
2. Select the Data Fields tab. If applicable, the path and filename of the currently 
connected database appears below the Use the data fields defined in the 
database option.

3. Click Other Database. The Open Database dialog box appears (see Figure 3).

Figure 3  Open Database dialog box

4. Select the type of database to be used (either JET or ODBC). 

• For a JET database, select the Use an Access (JET) database option and 
type in the path and filename of the new database, or click Browse to 
navigate to it. 

• For an ODBC database, select the Use an ODBC database option and 
select a database source from the Database ODBC connection string list (if 
required, input the database name and owner information), or click Data 
Source to access the Microsoft ODBC Data Source Administrator.

EPIDesigner automatically reconfigures itself to use the information stored in 
the selected database.

5. Click OK.

Set Up Custom Data Fields

If you are not connecting to a database for data retrieval but there are entry fields 
where data will be entered, you can add custom data fields to your card layouts 
that will be populated at print time. To do this, follow these steps:

1. On the View menu, click Options, and then select the Data Fields tab. The data 
field options appear.

2. Select the Use a custom list of data fields option. The Display name and 
Internal name fields below become enabled.

3. In the Display name field, enter the label that will appear in the data fields list. 
In the Internal name field, enter the name that will be used by your application 
to associate data with the dynamic object linked to the field. If these will be the 
Badge Designer Manual for Picture Perfect v4 and Secure Perfect v6
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same name, simply enter the name in the Display name field and click Add. 
The name will appear in both fields.

Printers
You will need to set up a printer before creating and designing cards. All necessary 
printer and page information is stored in the card design file (.DGN), which in turn 
is used by your application as a card format (a packet of information that includes 
the EPIDesigner card design file, the card code generation method, and the printer 
and page setup).

IMPORTANT: To ensure accurate reproduction of your card design, be careful to 
match the card size in your Layout Properties (described below) to the card 
media in your printer. If necessary, consult your printer’s documentation.

Install a Printer Driver

Install the printer drivers according to the instructions provided by your printer 
manufacturer. The printer appears automatically in the Print dialog box, the next 
time you sign into the system.

Set Up a Card Printer

To set up a card printer other than your default printer, follow these steps:

1. On the File menu, click Page Setup. The Page Setup dialog box appears with 
the Page Setup tab showing (see Figure 4).

Figure 4  Page Setup dialog box
The EPIDesigner Workspace - Printers
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2. Select a printer. The default printer (as specified in the Windows Printers 
control panel) appears in the list. To select a different printer, scroll through the 
list and choose from the printers displayed.

3. (Optional) Select the Print Color and K planes on separate pages option if 
your card printer outputs four process colors (cyan, magenta, yellow and black) 
when they are specified on separate document “pages”. The first page should be 
in CMY, and the second page should be monochrome. This option merges the 
two pages into one in order to output four-color process. Consult your printer 
manufacturer’s documentation on setting up your printer for K plane printing.

Note: Do not modify the Page Margins and Page Layout settings if you are 
printing to a card printer. See “Special Printing Options” on page 1.16 for more 
details.

4. Click OK. The dimensions of the card layout will adjust to those of your 
printer’s default card media. 

Special Printing Options

If you want to print cards to a sheet printer from your application, you will need to 
set parameters such as page margins, number of cards per page, and duplex 
printing using the options described in the following section. You can also use the 
following options to create a report that can be printed from your application to a 
document printer. 

To modify the printer settings (from the default printer driver settings) such as 
paper size or orientation, follow these steps:

1. On the File menu, click Page Setup. The Page Setup dialog box appears with 
the Page Setup tab showing (see Figure 4).

2. Click Properties. The Properties dialog from your printer’s driver appears. If 
available, set the options that you want to modify.

3. Click OK to save the settings.

Printing Reports To create a multi-card output (for example, a report or for sheet-printing), follow 
these steps:

1. On the File menu, click Page Setup. The Page Setup dialog appears.

2. Indicate the number of cards to be printed across the page in the Cards Across 
field.

Note: A landscape page allows for more cards to be printed across than a 
portrait page, although you will not be able to print as many cards down.
Badge Designer Manual for Picture Perfect v4 and Secure Perfect v6
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3. Indicate the number of cards to be printed down the page in the Cards Down 
field.

Note: A portrait page allows for more cards to be printed down than a 
landscape page, although you will not be able to print as many cards across.

4. (Optional) Adjust the horizontal and/or vertical spacing between the cards 
printed on the page.

5. Enter the new page margins in the fields as required.

Note: The default is “0” which allows the card printer to print edge to edge on 
the card media. If printing to a document printer, you may need to adjust these 
margins manually if this doesn’t occur automatically.

Headers and Footers

You can add headers or footers to your card layout that will appear at the top and 
bottom of the printed card or sheet. The objects you add to these areas will be 
saved in the card layout file (DGN).

IMPORTANT: The heights of the Header and Footer are added to the height of 
the card layout--they do not overlap the card layout. When setting up the Size 
Height of the header and/or footer, you must subtract those amounts from the 
height of the Front of the layout, otherwise your header will push the card layout 
(front/back) down the full height of the header, and the layout will in turn push 
down the footer. As well, if your printer requires margins (that is, does not print 
edge to edge) you will need to take those into account when you calculate your 
heights.

1. With a card layout open, on the File menu, click Layout Properties, and then 
select the Page Header (or Page Footer) tab. The options appear.

2. Select a page size (preferably the size of your layout Front/Back).

3. Modify the Header/Footer Size Height (and Front/Back height) as described in 
the note above.

4. (Optional) Add a background image or color. If you want this background to 
print at print time, select the Print background option.

5. Click OK.

6. To add objects to the header or footer, on the View menu, click Show, and then 
select Layout Header (or Layout Footer). A blank layout appears on the 
workspace.

7. Add objects such as text in the manner described in “Drawing Objects” on page 
1.30.
The EPIDesigner Workspace - Printers
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Double-sided Printing

There are two settings available for double-sided printing:

• Printing on both sides of a single card from the Print command (in either EPIDe-
signer or your application); 

or 

• Printing both sides of the card layout to a larger printer media from your appli-
cation to a document printer (to print on a sheet or create a report, for example). 

The first requires you to choose the appropriate Print Side setting on the Print 
dialog at print time, and the second requires you to choose a Page Setup option 
that will be saved in the DGN file and used when printing from your application.

Print Side Note: This option is used for single card printing (from either EPIDesigner or 
your application) or batch printing (from your application).

Figure 5  Print dialog

When you choose the Print command, you will have the following options:

Front Side Only -Prints only the front layout of the card.

Back Side Only -Prints only the back layout of the card.

Front and Back -Prints both the front and back layouts of the card. This selection 
should be used if you have a specialized printer that prints on both the front and 
the back of cards, or if you want to manually flip the cards over to print on their 
backs.

Note: If you want to manually flip cards over to print on their backs -- especially 
if you are printing both sides of the cards in batches -- you should know that this 
method will require a moderate amount of trial and error before you achieve 
satisfactory results.
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Duplex Settings Use these settings to print layouts on both sides of the printer media or to print 
both sides of the layout on one side of the media. These options are saved to the 
layout file (DGN) and used to create reports or for sheet printing on a larger 
format printer.

Note: This does not affect the way your card layouts will print to a card printer.

1. On the File menu, click Page Setup. The Page Setup dialog box appears with 
the Page Setup tab showing (see Figure 4).

2. Select the Duplex tab. The Duplex printing properties appear.

3. Choose from one of the following options:

Print fronts and back on same page -Used for printing double-sided layouts 
together on the front of the print media.

Print fronts and backs on separate pages -Used for printing double-sided 
layouts on opposite sides of the print media. 

• Default sequence - Prints fronts and backs in the same sequence on both sides.

Note: The fronts and back of the cards will not back to back on both sides of the 
print out. Use Align backs with fronts to achieve this effect.

• Align backs with fronts (page flips left to right) - Prints fronts to backs, 
flipping the media left to right.

• Align backs with fronts (page flips top to bottom) - Prints fronts to backs, 
flipping the media top to bottom.

4. Click OK.
The EPIDesigner Workspace - Printers



20
NOTES: 
Badge Designer Manual for Picture Perfect v4 and Secure Perfect v6



21
Using EPIDesigner

Selecting Page Sizes
Different types of ID cards come in different sizes dependent on the types of cards 
a printer will output. It is important to select the card page size before beginning to 
design a card, since resizing the page can have a serious impact on the overall 
design. The page size information is stored in the card layout file (DGN or GDR) 
and is used by your application during the printing process.

Set Up the Page Size

1. On the File menu, click Layout Properties. The Layout Properties dialog box 
appears (see Figure 6).

2. Click the Front tab. Front layout properties appear.

Figure 6  Page Setup dialog box

3. Select the required card size from the options listed in the Size list, or select 
Custom Size to specify your own dimensions in the Height and Width fields 
provided.

Tip: To get the maximum printable size for your printer, choose Full Printer 
Page from the Size list.

4. Select the card’s orientation on the printed page as either Portrait or 
Landscape (see Figure 7).
Using EPIDesigner - Selecting Page Sizes
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Note: This affects only the orientation of the cards, and is not connected to the 
orientation of the page, which is determined in the Printer Properties dialog. 
See “Printers” on page 1.15..

Figure 7  Landscape Card Layouts

5. Click OK.

Note: These settings will automatically be the same for both the front and back of 
the card layout.

Creating New Card Designs

When you launch EPIDesigner, it automatically opens a blank layout. You can 
create a new layout at anytime by following these steps:

1. Specify the appropriate card size information (see “Using EPIDesigner” on 
page 21).

2. On the File menu, click New, or click New on the Toolbar. EPIDesigner opens a 
design window for the front of the card. To view the back of the card layout, 
click Flip Layout on the toolbar, or on the View menu, click Show, then click 
Back of Layout.

3. Design your card using the various drawing tools. Import a card background 
from the Front tab on the Layout Properties menu. See “Importing the Card 
Background” on page 1.24..

Opening Existing Card Design Files

Opening an Existing Card Design File

1. On the File menu, click Open, or click the Open button on the Toolbar. The 
Open dialog box appears.

Landscape cards on a landscape page Landscape cards on a portrait page
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Figure 8  Open dialog box

2. In the File name field, type the name of the card design you want to open (or 
select it from the list). If the card design you want to open was originally 
created using GuardDraw (version 4.x or later), EPIDesigner will display 
existing layouts with both the DGN and GDR extensions.

Note: If the card design is in another drive or directory, browse to it using the 
Look In list. You will only be able to access network drives that are mapped to 
your PC or available from your Network Neighborhood.

3. Click Open.

Opening a Recently Saved Card Design

The last four card designs that were saved to disk will be listed at the bottom of 
the File menu. Select the name or number of the card design that you want to open 
and it will be displayed.

Saving Card Designs
The Save command displays a dialog box where you can give a new card design a 
filename, and specify a location in which to store it.

Saving a Card Design For the First Time

To save a card design for the first time, follow these steps:

1. On the File menu, click Save. The Save As dialog box appears (see Figure 9).
Using EPIDesigner - Saving Card Designs
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Figure 9  Save As dialog box

2. In the File name field, type a name. From the Save as type field, select .DGN 
or .GDR. See IMPORTANT note below.

Note: To save the card design in a different drive or directory, select the drive 
from the Save In drop-down list. You will only be able to access network drives 
that are mapped to your PC or available from your Network Neighborhood. 

3. Click OK.

Saving Previously-Saved Card Designs

After making changes to an existing card design, save your changes by clicking 
the Save button on the toolbar, or on the File menu, click Save. Your changes are 
automatically saved to the file. To save the design with a new filename, on the File 
menu, click Save As and follow steps 2 and 3 above.

IMPORTANT: If you open a GuardDraw file (GDR) and then save it without 
changing the filename, you will overwrite that file and will no longer be able to 
open that file using GuardDraw even though it will still have the .GDR extension. 
If you need to keep your old GDR or DGN files, always save with a new filename.

Importing or Removing the Card Background
Card backgrounds consist of graphics (such as bitmap images), which are created 
in draw or paint programs. The background is the graphical “landscape” against 
which the various card design objects (such as images or text objects) are placed.

Note: You can also apply these features to Back, Header and Footer layouts. On 
the View menu, click Show.

Importing the Card Background

To import card backgrounds, follow these steps:
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1. On the File menu, click Layout Properties. You can also click the Layout 
Properties button on the toolbar, or double-click the layout.

2. Select the Front or Back tab. 

3. In the Background area, click Load. The Open dialog box appears.

4. In the File name field, type the name, path, and extension of the background 
file (or use the buttons to browse to your file).

5. Click OK. The Enhance, Delete and Save As buttons are enabled. 

6. (Optional) Make any modifications to the image. See “Enhancing the Card 
Background” on page 1.25. for more information about the enhancement 
options.

7. Click OK. The card background is placed on the front or the back of the card 
design (depending on which was selected).

Enhancing the Card Background

When a background image is added to a card design, the Enhance button on the 
appropriate Layout Properties tab is enabled. This gives you access to the various 
enhancement options available for your background images--cropping, color 
balance, as well as exposure, contrast and brightness.

IMPORTANT: When creating a background image for your card layout (using a 
graphics software), be sure to use the same dimensions (or at least the same aspect 
ratio) for your background as your card media. If your image does not match your 
card media, as set in the Card Size list, EPIDesigner will stretch the image as 
required to fill the card layout. This is also important to remember if you choose to 
crop your background image.
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Figure 10  Image Enhancement Dialog

To modify any of the color or image quality settings, drag the slider one way or 
another until the Preview Image appears as desired, or select Automatic contrast 
to automatically adjust the contrast of the image. Click OK when you are finished. 
To undo your changes click the Reset All button to return the Preview Image to its 
original settings, or click Cancel to return to the Layout Properties dialog 
without saving the changes. 

To crop the background image, drag one of the eight sizing handles that appear on 
the Original Image until the image has the desired shape. You can also move the 
cropping area (if it is smaller than the original image) by dragging it to the desired 
area on the Original Image.

Removing a Card Background

To remove a background from a card design, follow these steps:

1. On the File menu, click Layout Properties, and then click the Front or Back 
tab (depending on which background you want to remove).

2. Click the Delete button then click OK to return to the EPIDesigner workspace 
or repeat the instructions for importing an image (see “Importing the Card 
Background” on page 1.24).

Export a Card Background

To export a card background, on the File menu, click Layout Properties, or click 
the Layout Properties button on the toolbar. Click the Front tab. When there is 
currently a background image on the layout, the Save As button is enabled. Save 
the image file with a new name, define the file type, and specify the directory to 
which it will be saved.
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Change the Background Color

This feature allows you to add a solid color to your card’s background. This color 
will be printed on your finished card.

Note: If you use both a background color and a background image file, the 
background color will be covered over by the image file and will not be visible. 

To change the card’s background color, perform these steps:

1. On the File menu, click Layout Properties, or click the Layout Properties 
button on the toolbar. 

2. Click the Front or Back tab. Click the Color list to choose one of the sixteen 
preset colors or click the ellipses button next to it to define a custom color using 
the Windows color dialog box. Click OK.

To remove the background color, select the X from the top of the preset color list. 
This removes any background color previously applied to your card design.

Inhibit Printing the Background Image

If your card media comes with the background image preprinted on it, you can still 
include the image file in the layout (to make layout design easier) without printing 
it on the card. To do this, perform these steps:

1. Import the background image file that appears on your preprinted cards.

2. On the File menu, click Layout Properties, or click the Layout Properties 
tool. Click the Front or Back tab. Clear the Print background option selection 
below the Background commands. The image will appear on your design in 
EPIDesigner but will not print on the card.

Design Objects
EPIDesigner comes complete with an extensive selection of tools to allow you to 
design cards with ease. In addition to text, image and bar code objects, you can 
also use lines, circles, squares, rectangles, and ellipses to spice up your illus-
tration, or to create security clearance symbols for the easy identification of 
unauthorized cards.

Note: You can apply these features to Back, Header and Footer layouts. On the 
View menu, click Show and then choose the appropriate layout.
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Object Properties

All of the drawing tools available for your card layouts have properties (see “The 
Toolbar” on page 9); for example, position, line color, and conditional display 
options. All of the common object properties are described in the following 
section. Special properties that apply only to specific tools are described 
separately.

General Tab Figure 11  Object Properties General Tab

Size and Position fields -Use these fields to precisely place an object on the 
layout. Enter numbers in these fields to modify the object’s location and/or size. 
The number entered in each field indicates the location of that side of the object; 
therefore, changing a single position field will modify the size (and possibly the 
shape) of the object. To place an object on the design without calculating the 
border coordinates, enter only the width and height of the object and the distance 
to the edge of the card.

Note: To change the units of measurement, in the View menu, click Options, then 
click Rulers and Grids.

Style settings -Use these settings to define the color and thickness of the line 
framing the object, and the fill color.

Shadow -Use this option to add a drop shadow to any type of Text or Image object 
(static or dynamic). A drop shadow gives a sense of depth and dimension to a 2D 
object. The shadow is simply a duplicate of the object, offset from the original and 
filled with solid color. See “Create a Shadow” on page 1.44. for a sample image 
and more information.
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Roundness -Use this option to set the curvature of the rounded corners of a Round 
Rectangle. See See “Edit Rounded Corner Curvatures for a Rounded Rectangle” 
on page 1.32..

K and O plane settings -Use these settings to print the selected object on either 
the K or O plane of the printer’s ribbon. See “Placing Objects on the K and O 
Planes” on page 1.54..

Conditional Display
Tab

Figure 12  Object Properties Conditional Display Tab

Conditional Display options are used to set the conditions under which the object 
will appear. For example, if you want to print the object only when the 
Department field (maintained in the database) contains the word “Accounting”, 
follow these steps:

1. Select Department from the list.

2. Select “=” from the Compare list. 

3. Type Accounting in the data entry field.

The selected object will only be printed on cards that are issued to members of the 
Accounting department.

A smart feature allows you to type date and time values into the Data Entry field 
and EPIDesigner will recognize them as such. For example, if you typed “01/01/
01”, EPIDesigner will recognize that as the date January 01, 2001.

Always Show Object -(Default) Select this option if you want to print the object 
on all ID cards.
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Show Object Only When Field/Expression -Select this option if you want to 
print the object on specific cards. The fields beneath this option will be enabled.

Compare list

• < (less-than) - indicates the contents of the field you selected should be less 
than the value entered in the corresponding Value box.

• <= (less-than or equal-to) - indicates the contents of the field you selected 
should be less than or equal to the value entered in the corresponding Value 
box.

• <> (not-equal-to) - indicates the contents of the field you selected should not 
be equal to the value entered in the corresponding Value box.

• = (equals) - indicates the contents of the field you selected should be equal 
to the value entered in the corresponding Value box.

• > (greater-than) - indicates the contents of the field you selected should be 
greater than the value entered in the corresponding Value box.

• >= (greater-than or equal-to) - indicates the contents of the field you selected 
should be greater than or equal to the value entered in the corresponding 
Value box.

• Not Null - indicates the contents of the field you selected should be not null 
(filled with any type of information). You do not need to enter a value if you 
select this option.

• Null - indicates the contents of the field you selected should be null (empty). 
You do not need to enter a value if you select this option.

Drawing Objects

Drawing an object on the card layout is essentially the same for all object types. 

Draw an Object

1. Choose the appropriate tool on the Toolbar.

2. Move the mouse to the workspace.

3. Press and hold the left mouse button to anchor one end or corner of the object, 
and drag the pointer. A flexible line stretches from the anchor point to the new 
pointer position.

4. Release the left mouse button when the dimensions of the object are satis-
factory.
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Edit an Object

1. Select the object. Handles appear at each corner.

2. Position the mouse over one of the handles, then press and hold the left mouse 
button.

3. Drag the pointer to a new position on the editing screen.

4. When you are satisfied with the line, release the left mouse button.

Double-click the object and make any changes in the <object> Properties dialog 
box.

Set the Default Object Properties

By setting the default object properties, you can customize the appearance of the 
Line Color, Line Weight and Fill Color for all drawing objects. To do this, follow 
these steps:

1. Draw an object on the layout then make all modifications necessary.

2. On the Object menu, click Set Default Properties. All subsequent objects will 
automatically have those new settings when drawn.

Remove or Modify a Border

By default, a line runs around the perimeter of all newly created objects (except 
bar codes) that can either be modified or removed.

To remove the line, select the large X at the top of the line color list on the 
Attribute bar. 

To add border text, select AAAA from the list. See “Adding Border Text to 
Objects” on page 1.38. for more information.

To change the color, select a color from the list, or create a custom color in the 
<object> Properties dialog box. 

Remove border
Border Text

Preset colors
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Edit Rounded Corner Curvatures for a Rounded Rectangle

1. After you have drawn the round rectangle, a special handle appears inside the 
upper right-hand corner of the rounded rectangle. Position the mouse over the 
handle and the pointer changes from a single-headed arrow to a four-headed 
arrow.

2. Hold down the left mouse button and drag the handle toward the center of the 
object to increase the curvature of the rounded corners, or away from the center 
of the object to decrease the curvature.

3. When you are satisfied with the rectangle’s new shape, release the left mouse 
button.

Note: You can also modify the curvature using the Roundness options of the 
Properties dialog. The Horizontal and Vertical entries indicate how far from the 
respective corners the curves should start.

Moving and Aligning Objects

Dragging objects with the mouse allows you to position them interactively.

Move Objects

1. Highlight the object you want to move using the Select tool.

2. Drag and drop the object at its new location.

Alternatively, you may select the object and press any of the keyboard arrow keys 
to move it. This is called “nudging”.

Copy or Duplicate Objects

1. Highlight the object you want to copy using the Select tool.

2. Press and hold the CTRL key, and then drag and drop the copy to its new 
location. This creates a copy of the object and leaves behind the original.

Note: You can also perform this task using the Copy and Paste tools.

Align and Distribute Objects

The Align function allows you to select several objects on your card design and 
align them by their left, center, or right points, and/or their top, middle, or bottom 
points. You can also align objects according to their text baselines.

The Distribute function allows you to select several objects and space them 
evenly either vertically or horizontally on your design.
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To align or distribute several objects, follow these steps:

1. Select several objects by holding down the SHIFT key and clicking on the 
objects of your choice.

2. On the Object menu, click Align or Distribute, and then choose the appro-
priate command from the menu that appears.

Resize Multiple Objects

You can select two or more objects and resize them all to the same criteria. For 
example, if you draw a square and a circle on the layout and want them to be the 
same dimensions, select them both (by Shift-clicking). Then on the Object menu, 
click Size, and then choose one of the following options:

To Tallest -Resizes the shorter object(s) to the same height as the taller (or tallest) 
object.

To Shortest -Resizes the taller object(s) to the same height as the shorter (or 
shortest) object.

To Widest -Resizes the narrower object(s) to the same width as the wider (or 
widest) object.

To Narrowest -Resizes the wider object(s) to the same width as the narrower (or 
narrowest) object.

Note: These commands do not maintain the objects’ aspect ratios.

Rotate Objects

To rotate objects, perform these steps:

1. Select the object you want to rotate.

2. On the Object menu, click Rotate 90 Degrees.

3. Click Left to rotate the object counterclockwise, or click Right to rotate the 
object clockwise.

4. Repeat until you are satisfied with the object’s appearance.

Note: Rotating can be used to design duplex cards with different front and 
back page orientations.
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Flip Objects

The Flip function allows you to create a mirror image of an object by inverting the 
object either vertically (from right to left) or horizontally (from top to bottom). To 
flip an object, follow these steps:

1. Select the object to be flipped.

2. On the Object menu, click Flip. The Flip submenu appears.

3. Click either Left - right, or Top - bottom.

Figure 13  Flip Object Samples

Note: This function is not available for bar codes or text objects.

Resize an Object

To resize an object, perform these steps:

1. Highlight the object using the Select tool. Handles appear on the sides and 
corners of the object.

2. Position the mouse over one of the handles, then press and hold the left mouse 
button.

3. Drag the pointer to a new position on the editing screen.

4. When you are satisfied with the object’s new size and shape, release the left 
mouse button.

You cannot resize static text objects, in the sense that the point size of the font will 
be increased or decreased as you stretch the text box. Rather, when you resize the 
text box, you expand or contract the amount of available space in which the text 
will fit. This is particularly important if you increase the font’s point size, or if you 
type too much text to fit within the text box. To reveal text that has been hidden 
due to constraints in the size of the text box, follow the instructions above.

Changing Object Attributes

You can change object attributes, such as line weight or fill color, at any time 
while you are creating or editing the card design.

Original Left-Right Top-Bottom
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Change Line Attributes

To change line attributes, perform these steps:

1. Double-click the line you want to change. The Line Properties dialog box 
appears.

2. On the General tab, change the line color by choosing from the sixteen quick-
access colors in the Line Color list. For a more extensive selection of colors, 
click the ellipsis button next to the Line Color list.

3. Click Line Thickness and select from the list.

Change Object Attributes

To change object attributes, perform these steps:

1. Double-click the object you want to change. The <object> Properties dialog 
box appears.

2. On the General tab, change the object color by choosing from the sixteen quick-
access colors in the Line Color list. For a more extensive selection of colors, 
click the ellipsis button next to the Line Color list.

3. Change the fill color by selecting from the sixteen quick-access colors in the 
Fill Color list. For a more extensive selection of colors, open the <object> 
Properties, click the General tab, and then click the ellipsis button next to the 
Fill Color list.

4. If the object is static or dynamic text, change the text color by selecting from 
the sixteen quick-access colors in the Text Color list. For a more extensive 
selection of colors, click the ellipsis button next to the Text Color list.

Adding Static and Dynamic Text

The are two types of text objects in EPIDesigner: static and dynamic. Static text 
objects are used as non-changeable design elements such as headlines or field 
labels (for example, “First Name”). Dynamic text/data objects are connected to a 
data field or expression, and change from card to card (for example, the first name 
of the cardholder).

The links between the database (or data field in certain cases) and your card 
design are created automatically. You only have to select the font, style, point size, 
color, and location of both the data fields/expressions and the text objects.

Create Static Text Objects

To create static text objects, perform these steps:
Using EPIDesigner - Design Objects



36
1. On the Draw menu, click Static Text, or click the Static Text button in the 
Toolbar.

2. Draw the object (as described in “Draw an Object” on page 1.30). The Text 
object will appear on the workspace (see Figure 14).

Figure 14  Static Text Object

3. Double-click the object. The Static Text Properties dialog box appears.

Figure 15  Static Text Properties Dialog

4. Select the Text tab. In the Text field, enter the text you want to appear. 

5. If the text is long, select the Wrap text option so that the text wraps to the next 
line within the boundaries of the object, or select the Automatically reduce 
font to fit option to have EPIDesigner shrink the text to fit into the object 
without wrapping. If you want a long text string to appear with specific line 
breaks, you can force a break by pressing Ctrl+Enter where you want the line 
to wrap.

6. (Optional) Select Vertical Text to display the text vertically (top to bottom).

7. (Optional) Click Change Font to select the font, style, and point size.

8. (Optional) Click Text Color to select one of the preset colors, or click the 
ellipsis button to access the Windows Color palette to create a custom color.

9. (Optional) Adjust the text justification using the Justification options.
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Note: You can change any of these options later by highlighting the text object 
and making your choices on the Text Style and Attribute bars. See “The Text Style 
Bar” on page 1.10..

10.(Optional) To add a border or background color to the text object, click the 
General tab and then select the text box line and fill colors.

11.(Optional) Adjust the text box Line Thickness.

Create Dynamic Text Objects

To create dynamic text objects, perform these steps:

1. Using the Dynamic Text tool, draw the object as described in “Draw an Object” 
on page 1.30.

Figure 16  Dynamic Text Object

2. Double-click the object to open the Dynamic Text Properties dialog.

Figure 17  Dynamic Text Properties dialog

3. Click the Text tab. From the Data field name or expression list, select the data 
field that will supply the data at print time. Click Edit if you want to customize 
the data field.
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4. (Optional) In the Sample Text field, enter a label that will identify the contents 
that will appear in the object at print time (for example, First Name).

5. Make any further modifications to the object as described in see “Create Static 
Text Objects” on page 35.

Adding Border Text to Objects

This security feature allows you to add a border of very small, user-definable print 
around rectangle, text and image objects, both static and dynamic. 

Figure 18  Sample Border Text

Note: The settings for the Border Text will be global for your card layout, so you 
only need to set the properties once in the Layout Properties dialog.

Set the Border Text Properties

To set the border text properties, perform these steps:

1. On the File menu, click Layout Properties, or click the Layout Properties 
button on the Toolbar. The Layout Properties dialog box appears.

Border text set to 3 points Border text set to 7 points
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Figure 19  Layout Properties dialog

2. In the Text field, enter the text that will appear around the design object. This 
word or phrase will be repeated until there is no more room and the last 
iteration will be truncated to fit. The text will begin at each corner as shown in 
Figure 18. 
Tip: Add a space after the last word to create a buffer between it and the first 
word so they don’t run together.

3. Click the Color list to select a color for the text. For a more extensive selection 
of colors, click the ellipsis button next to the Color list.

4. Click Modify... to change the default font setting of Arial 3 point in black. The 
options available are similar to those offered on the Text Style bar. We 
recommend that you keep the font size very small, 3 points being the smallest. 
You may need to experiment with the size to find what works best with your 
printer.

Keep in mind also that the keyline or outside perimeter for your object becomes 
the baseline (or outermost point) of the text, therefore any border text will 
reduce the size of the image. The samples above were created from the same 
image object. You can see that the larger font size reduces the space available 
for the image.

5. Click OK to accept the changes.

Add Border Text to an Object

1. Add your Rectangle, Text or Image object to the card.
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2. With the object still highlighted, choose AAAA from the Line color list to set 
the line to border text. Your object will appear similar to the samples in Figure 
18.

Adding Static and Dynamic Images

You can use a drawing tool to add digital images to a card, such as photographs, 
fingerprints, signatures, and clip art. The Dynamic Image tool is used to create a 
keyline for any dynamic image type available in EPIDesigner. The Static Image 
tool allows you to import static image files from any external source.

Dynamic Image keylines are automatically linked to your data source. When you 
print cards using your application, the keylines are replaced by the cardholder’s 
images. Hard-to-counterfeit transparent images and cameo effects can also be 
defined for the image keylines, therefore, providing an extra level of security to 
the cards issued.

Add Static Images

To add a static image, perform these steps:

1. On the Draw menu, click Static Image, or click the Static Image button on the 
Toolbar. 

2. Draw the image object (as described in “Draw an Object” on page 1.30). The 
Open dialog box appears when you release the mouse button.

3. Browse to the image file you want to insert in the keyline, then click Open.

Note: The image size is automatically set to match the size as specified in the 
image file header.

Add Dynamic Images

To add a dynamic image, perform these steps:

1. On the Draw menu, click Dynamic Image, or click the Dynamic Image button 
on the Toolbar.

2. Draw the image object (as described in “Draw an Object” on page 1.30). The 
object will maintain the aspect ratio as set in your application for the default 
image type (for example, Photograph).

Change the Image Properties

To change the image properties, perform these steps:
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1. (Optional) Change the image properties by double-clicking the object to access 
the Dynamic Image Properties dialog box. Select the Image tab.

Figure 20  Dynamic Image Properties dialog

2. Change the Image Type by choosing from the list.

Note: These options will differ depending on the product you have purchased.

3. (Optional) Select Print image exactly as-is to prevent changes to an image so 
that it prints correctly. Use this feature for bitmaps that contain digital water-
marks which may be lost if the bitmap is resized.

Note: When you select Print image exactly as-is, other properties for the image 
are disabled, such as line color and thickness, shadow, close-cropping, fading 
transparency, and gray scale. However, the checkbox Don’t clip image becomes 
enabled, allowing you to print the entire image even if it is too large to fit in its 
rectangel as defined on the layout.

4. If applicable, select the data source field that points to the image.

Select a Sample Image

If you want to add effects to your dynamic images, it’s a good idea to select a 
sample image so you can preview the effects prior to printing. Perform these steps:

1. Double-click the image to open the Dynamic Image Properties dialog box. 
Select the Sample Image tab.

2. Click Load. The Open dialog appears.

3. Select an image that is a good representation of the typical image you will be 
capturing with your application. Click Open.
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4. Click Enhance to make any enhancements necessary (see “Enhancing the Card 
Background” on page 25 for more details). These enhancements only affect the 
sample image and not the images that will be added at print time.

5. Click OK.

Add Close-Cropping Effects

The Close-cropping option allows you to remove the background pixels from an 
image. On the Image Properties dialog box, click the Image tab. Select the 
Close-cropping checkbox, then click Settings. The options you select depends on 
the image quality of the background you want to remove. 

Cameo Effect -Select this option if you want to create a cameo effect. This will 
remove all background pixels around the subject of the image (i.e., the 
cardholder's head). Use this option with the Fade and Transparency levels to 
make an interesting ghost effect.

Hue/Intensity Color Match -Select this option if you want to remove all pixels 
within a specified hue/intensity range. This option is particularly useful if you are 
having trouble removing background pixels with the RGB Color Match option. 
Enter your custom Color Variation and Intensity Threshold percentages.

RGB Color Match  -Select this option if you want to remove all background 
pixels that are exactly the same color. This option is particularly useful for solid-
color backgrounds, which are commonly found in bitmap files (for example, 
logos), and it may not be suitable for cropping photographs. In the Color 
variation field, enter an amount of variation from the selected color, or enter 0 for 
an exact color match.

Color Variation -This is the percentage of the hue that EPIDesigner will use to 
scan for variations of the background pixels along the color spectrum. EPIDe-
signer removes pixels by sampling the first one located in the upper left-hand 
corner of the image. It then uses this setting to scan for pixels of a similar hue 
along the specified percentage of the color spectrum. A higher value means that 
EPIDesigner will scan and remove pixels across a wider percentage of the color 
spectrum. A lower setting means that EPIDesigner will confine the removal to 
pixels that more closely match the first one that was sampled.

For example: If you enter a setting of “30” here, and if the image's first pixel is a 
shade of green, EPIDesigner will scan and remove all shades of green across 30 
percent of the spectrum (and possibly into portions of the yellow and blue color 
ranges).

Intensity Threshold -This is the percentage that EPIDesigner will use to scan for 
variations in color intensity. EPIDesigner removes pixels by sampling the first one 
located in the upper left-hand corner of the image. It then uses this setting as a 
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threshold by which all pixels of a certain intensity (and higher) will be scanned. A 
higher value means that EPIDesigner will confine its removal to the brighter 
pixels that fall within the specified Color Variation range. A lower setting means 
that EPIDesigner will widen its scan and remove a broader range of bright and 
dark pixels within the specified Color Variation.

For example, if you enter a setting of “60” here and a setting of “30” in the Color 
Variation box, and if the image’s first pixel is a shade of green, then EPIDesigner 
will scan and remove all of the brighter shades of green across 30 percent of the 
color spectrum. In other words, fewer green pixels will be removed from the 
image. If, on the other hand, you lowered this setting to “20,” the removal will 
include a broader range of both light and dark green pixels.

Background Color -If Automatic is selected, EPIDesigner removes pixels by 
sampling the top-left and top-right pixels of the image and estimating the 
background color. To select a different color, click on the color in the displayed 
image, or check the Specific color box and then click Choose color. Select the 
color and then click OK.

Create an Image Ghost Using the Effects Settings

The Fade and Transparency levels can be used to create a ghost image. An image 
ghost is an image that is transparent (that is, the background elements show 
through it) generally used in addition to a regular image, and can be placed 
anywhere on the card design—even behind text or other objects. This is 
considered to be an additional ID security feature, as ghosted images are 
extremely difficult to reproduce.

You may want to experiment with the settings to get the effect you want.

1. Add an image object (as described in “Draw an Object” on page 1.30). If you 
want to create a ghost of an image that already exists on your card, Ctrl+click 
the image and drag the newly created image to its location. Then you can apply 
the effects you want to the new image. You will need to move the ghost behind 
the original; on the Object menu, click Move, then click Back.

2. Double-click the image to open the Dynamic Image Properties dialog box. 
Select the Image tab.

3. Modify the Effects settings to get the look you want.

• Fade level: Use this feature to create a “washed out” appearance. The number 
entered in the field represents the percentage of “whiteness” that you want for 
the image. 

• Transparency level: Use this feature to reduce the opacity of the image. The 
number entered in the field represents the percentage of the image that will be 
transparent. 
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• Use mesh pattern: This is a quick way to create a ghost effect and can be used 
instead of changing the Transparency level. It automatically sets the appropriate 
level of opacity. This option uses the same algorithm as the ghost option in 
GuardDraw 5.5.

• Gray scale: Select this option to remove the color information from the image—
the color will be replaced with levels of gray.

Create a Shadow

Create a shadow behind any text or image object, static or dynamic, giving a sense 
of depth and dimension to a 2D object.

Note: In the case of an image object, the shadow created will reflect the shape of 
the image’s keyline (outside border) and not that of the image itself (even if you 
select a close-cropping effect).

Figure 21  Shadow Samples

1. Double-click the image or text object to open the Properties dialog.

2. In the Style settings, click Shadow.

3. (Optional) Modify the color and offset of the shadow (keeping in mind what the 
object over the shadow will be).

4. Click OK. 

The default settings for the amount of offset are, horizontally and vertically, 0.04 
of the units of measurement you are currently using, and the color is black. These 
settings create a shadow appearing below and to the right of the object. To change 
these settings, perform these steps:

1. Select a new color from the Color list, or click the ellipses button next to it to 
change the shadow color. The Microsoft Color palette appears.

2. Type a new setting for the horizontal and vertical offsets. Positive integers 
create a shadow below (horizontal) and to the right (vertical), while negative 

Static Text object with shadow

Static Image object with
cameo effect and shadow
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integers create them above and to the left. Experiment to see the settings that 
are most appropriate for your design.

Tip: Create eye-catching portraits on your cards by adding a Cameo Effect to your 
image and then adding a shadow. Remove the object outline, change the shadow 
color, and increase the offset to enhance the effect. See Figure 21 on page 44.

Change Signature Fill and Text Attributes

Changing the fill color and/or text color of a signature can make it stand out more 
on your card design. Changing the text color results in your printed signature 
appearing in the chosen color.

1. With the signature selected, change the text and fill color by choosing from the 
sixteen quick-access colors in the Text Color list on the toolbar.

For a more extensive selection of colors, double-click the object to open 
Dynamic Image Properties. Click the General tab, and then click the ellipsis 
button next to the color list. To print the signature against the card background, 
click X for “no fill”.

Note: These two attributes will not change the appearance of your sample image 
(if you have chosen one); they will only affect the final printed card.

Defining Expressions

Define Expressions with a Database Connection

While EPIDesigner allows you to define any manner of valid SQL expressions, 
you will most likely combine available database fields (for example, First_Name 
and Last_Name). 

Note: You cannot use expressions if your configuration does not access textual 
data in your database.

SQL expressions that can be defined in EPIDesigner differ from database to 
database. Refer to the documentation that accompanies the ODBC-compliant 
database you are using.

Define Expressions with No Database Connection

In the case of a “no database” connection, that is, when your application provides 
data directly to the card layout without the use of a database, you can create 
expressions based on the data fields that are defined in the View menu, by clicking 
Options, and then Data Fields.

Note: For this feature to work properly, you must select the option Evaluate 
expressions in data fields on the General tab of the Layout Properties box.
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Define an Expression for a Conditional Display

You can choose a combination of data fields that can be used as display criteria for 
a design object. For example, if you want a design object to appear only when the 
cardholder’s name equals “John Smith”, then you will need to create an expression 
that reflects that condition.

1. Double-click the object to open the Properties dialog box.

2. Click the Conditional Display tab.

3. Click the option Show object only when field/expression. The fields below 
become active.

4. From the Data field list, select your valid SQL database expression.

Figure 22  Dynamic Image Properties Dialog

Use Expressions as Dynamic Text Objects

You can use any expression when creating a dynamic text object, just as you 
would any regular database field. For example, if you want to show both the 
cardholder’s first and last names together, you would enter the appropriate 
expression in the Field Name combo box. 

The “Dynamic Text Properties Text Tab” on page 1.47 shows the SQL expression 
used to concatenate the First_Name and Last_Name fields together to create the 
“Full Name” expression. 

RTRIM[First_Name]+””+[Last_Name]

The RTRIM command at the beginning of the string is used in SQL to remove any 
blank spaces to the right that may exist in the database field. The pair of double 
quotes in the middle of the expression is a marker for a space in between the two 
names.
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If you do not have a database connection, the code entered would look something 
like this:

First_Name + ‘ ‘ + Last_Name

where First_Name and Last_Name are data fields that have been defined in the 
View menu, by clicking Options, then the Data Fields tab.

Note: To use expressions without a database connection, on the Layout 
Properties box, click the General tab, and select the option Evaluate expres-
sions in data fields. See “Define Expressions with No Database Connection” on 
page 1.45..

Figure 23  Dynamic Text Properties Text Tab

1. Double-click the Dynamic Text object to open the Properties dialog box.

2. Click the Text tab.

3. In the Data field name or expression box, enter the expression you want to 
use.

To create a custom field name or expression, click Edit. Select the field name 
from the list, then click Insert. Repeat to add more names or expressions. Click 
OK when you are done.

4. Because an expression can be lengthy, you can edit the label so it more closely 
resembles the expression’s intended purpose (for example, “Full Name”). 
Otherwise, EPIDesigner automatically uses the Field Name entry as the Text 
label.

5. (Optional) If the expression is a date or time field, select a format from the 
Format for date/time fields list.

6. Click OK.
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Adding Bar Codes

Drawing bar codes on a card design can be a moderately complex process. It is 
important to familiarize yourself with the type of bar code you will be using, and 
to set the corresponding properties, values, and database field specifications with 
care. Bar Code Properties and Values (below) contains descriptions of the various 
types of bar codes that can be added to your card design. You should first refer to 
your hardware documentation for information on the types of bar codes supported 
by the card reader you have purchased and the type of data the bar code can 
accept.

Drawing a Bar Code

To draw a bar code, perform these steps:

1. On the Draw menu, click Bar Code, or click the Bar Code button on the 
Toolbar.

2. Draw the bar code as you would any other design object.

Figure 24  Sample Bar Code with Readable Text

Link a Bar Code to a Data Field or Expression

In order for the bar code to convert and use the proper data from the data source, it 
is important that you link it to a data field. To do this, double-click the bar code to 
open the Bar Code Properties box. Click the Bar code tab, and then select a data 
field from the Field Name list.

Set Bar Code Properties and Values

To set the bar code properties and values, perform these steps:

1. Double-click the bar code to open the Bar Code Properties dialog box, or 
click the Object Properties button on the Toolbar. Click the Bar code tab.

2. Select the appropriate bar code type from the Type list. See “Bar Code Types” on 
page 1.49. for details.

3. Continue selecting properties and their corresponding values until you have 
properly configured your bar code. See “Bar Code Properties” on page 1.52. for 
details.
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Print Bar Codes on the K Plane

Bar codes should always be printed in black. There are two types of black 
available: process black and pure black (the black that is exclusively printed on the 
K plane). While both colors are an acceptable selection, it is important to note that 
infrared bar code readers cannot recognize bar codes printed in process black. 
Unless you are sure that your bar code reader can read process black, it is recom-
mended that you set your bar code to print in pure black.

To print bar codes on the K plane, double-click the bar code on your card design to 
open the Bar Code Properties dialog. Click the General tab, and then select 
Print on K Plane.

Note: This option is only valid if your card printer supports K plane (pure black) 
printing.

Set the Bar Code Background Color

While the default bar code background color is white, and should generally remain 
white, EPIDesigner allows you to specify any other color (including no color, or 
transparent) to prevent the illicit duplication of ID cards by photocopying. 

Note: Only a small number of readers can recognize the black code against a 
non-white field; therefore, if you intend to specify a bar code background fill as 
any color other than white, first make sure your reader is capable of distin-
guishing the code from the color field.

A good rule to remember when printing bar codes against a non-white field is to 
print the bar code on the K plane (see “Print Bar Codes on the K Plane” on page 
49 for more information).

To set the bar code background color, highlight the bar code on your card design. 
Change the bar code background fill color by selecting from the sixteen quick-
access colors in the Fill Color list on the Attribute bar, or open the Bar Code 
Properties dialog and click the ellipsis button next to the Fill Color list to create a 
custom color.

Types and Checksums

The following sections describe the bar code types that are available on the Bar 
Code tab of the Bar Code Properties box.

Bar Code Types This property is used to set the type of bar code to be used. The following is a list 
of the possible types of bar codes:

• Code 3 of 9 - an alphanumeric bar code allowing uppercase letters and numbers. 
Each character consists of nine elements, three of which are wide. An embedded 
CRC character is present. To add a checksum to the bar code, select an option 
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from the Checksum list.

• Extended Code 3 of 9 - this bar code type is similar to Code 3 of 9, except it 
allows the full 128 ASCII character set to be encoded by printing two bar code 
characters for each text character. To add a checksum to the bar code, select an 
option from the Checksum list.

• Interleaved 2 of 5 - a numeric bar code. Each encoded character is composed of 
five elements, two wide and three narrow. The number of characters to be 
printed must be even. If the number of characters is odd, a zero is appended to 
the beginning of the code. To add a checksum to the bar code, select an option 
from the Checksum list.

• Code 93 - an alphanumeric bar code allowing uppercase letters and numbers. To 
add a checksum to the bar code, select an option from the Checksum list.

• Extended Code 93 - this bar code type is similar to Code 93, except it allows 
the full 128 ASCII character set to be encoded. To add a checksum to the bar 
code, select an option from the Checksum list.

• UPCA - Universal Product Code version A. This bar code type is used to encode 
an 11 digit number. The first digit is the system number and the rest are data 
characters. Both two and five digit supplements are supported. Checksum is not 
used.

• UPCE 10 digit - a zero-compressed version of the UPCA bar code. This version 
allows 10 digits to be encoded. The first digit must be a zero. Both two and five 
digit supplements are supported. Checksum is not used.

• UPCE0 6 digit - a zero-compressed version of the UPCA bar code. This version 
allows 6 digits to be encoded. The first digit must be a zero. Both two and five 
digit supplements are also supported. Checksum is not used.

• UPCE1 6 digit - a zero-compressed version of the UPCA bar code. This version 
allows 6 digits to be encoded. The first digit must be a zero. Both two and five 
digit supplements are supported. Checksum is not used.

• EAN 13 - this bar code type is used when the country origin must be known. 
EAN 13 is composed of 13 digits. The first two characters are used to define the 
country of origin, the next 10 are data, the last is a checksum. Both two and five 
digit supplements are supported. Checksum is not used.

• EAN 8 - this bar code type is used when the country origin must be known. 
EAN 8 is composed of eight digits. The first two characters are used to define 
the country of origin, the next five are data, the last is a checksum. Both two and 
five digit supplements are supported. Checksum is not used.

• Code 128 Auto - a variable-length bar code that is capable of encoding the full 
128 ASCII character set. Code 128 allows three subsets: A, B and C. This 
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version automatically selects the subset that produces the smallest bar code. See 
Note below for special checksum information.

• Code 128 A - a variable-length bar code that is capable of encoding the full 128 
ASCII character set. Code 128 allows three subsets: A, B, and C. This version 
allows all standard uppercase alphanumeric keyboard characters, plus control 
characters. See Note below for special checksum information.

• Code 128 B - a variable-length bar code that is capable of encoding the full 128 
ASCII character set. Code 128 allows three subsets: A, B, and C. This version 
allows all standard uppercase alphanumeric keyboard characters, plus all 
lowercase alpha characters. See Note below for special checksum information.

Note: For Auto, A & B - Set the checksum to “Mod 103" to use the regular Code 128 
checksum value or to “Mod 43/Mod 103" to perform the HIBC standard Mod 43 encoding 
prior to the Code 128's Mod 103 checksum.

• Code 128 C - a variable-length bar code that is capable of encoding the full 128 
ASCII character set. Code 128 allows three subsets: A, B, and C. This version 
includes a set of 100 digit pairs, from 00 to 99 inclusively. This allows double-
density numeric digits: two digits per bar-coded character. A checksum is 
automatically chosen.

• Codabar - a variable-length bar code that is capable of encoding 16 characters, 
including 0 to 9, plus the symbols “-”, “$”, “;”, “.”, and “+”. It is used primarily 
for numeric data. Any one of “a,” “b,” “c”, or “d” must be used as the start and 
stop characters. To add a checksum to the bar code, select an option from the 
Checksum list.

• MSI Plessey - a variable-length bar code that is capable of encoding up to 15 
numeric digits. To add a checksum to the bar code, select an option from the 
Checksum list.

• UCC 128 - a specially-defined subset of Code 128 that is used primarily on 
shipping containers. It is numeric and has a fixed length of 19 digits. To add a 
checksum to the bar code, select an option from the Checksum list.

• POSTNET (Zip + 4 PostalCode) - this bar code type is used on envelopes and 
postcards that are shipped through the US Postal Service. It is placed on the 
lower right-hand corner of the envelope. Checksum is not used.

• Symbol PDF417 - a two-dimensional symbology that allows you to encode a 
Portable Data File with ASCII, binary, or numeric data. The Symbol PDF417 is 
particularly useful if you need to encode large amounts of data onto a limited 
space (for example, an ID card that requires customer or employee profiles, 
biometric data, and personal descriptions). See “Setting Up Symbol PDF417 Bar 
Codes” in the EPIDesigner Help system for complete details on the proper use 
of this technology.

Note: Symbol PDF417 bar codes are only available through an optional plug-in.
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• Code 49 - a multiple-row bar code that can encode the full ASCII character set 
below ASCII 128. Up to 49 alphanumeric characters or 81 numeric characters 
can be encoded. These characters are encoded into 2 to 8 rows, each divided by a 
separator bar. The top and bottom of the symbol also have separator bars that 
extend to the ends of the minimum quiet zones.

• Code 16K Auto - a multiple-row bar code that can encode the full ASCII 
character set below ASCII 128 using existing UPC and Code 128 character set 
patterns. Up to 77 full ASCII characters or 154 numeric characters can be 
encoded into 2 to 16 rows, and each row is divided by a separator bar. The top 
and bottom of the symbol also have separator bars that extend to the ends of the 
minimum quiet zones. Code 16K is similar to Code 128 in that you can choose 
between three subsets directly (A, B, or C), or you can choose Code 16K Auto 
for auto switching mode.

• Code 16K A - a multiple-row bar code that can encode the full ASCII character 
set below ASCII 128 using existing UPC and Code 128 character set patterns. In 
Code 16K A, you can encode punctuation, digits, uppercase letters, and control 
codes below the space character. 

• Code 16K B - a multiple-row bar code that can encode the full ASCII character 
set below ASCII 128 using existing UPC and Code 128 character set patterns. In 
Code 16K B, you can also encode lowercase letters, but not control codes below 
the space character.

• Code 16K C - a multiple-row bar code that can encode the full ASCII character 
set below ASCII 128 using existing UPC and Code 128 character set patterns. In 
Code 16K C, only digits can be encoded. This mode prints digits in double-
density compressed mode.

Bar Code Properties Sample Text -This property sets the sample text that replicates the data that will 
populate the bar code at print time. Each bar code has its own associated sample 
text, but you can modify it within the parameters of the bar code.

Field Name -Select the data field from which the data will be taken at print time.

Justification -Select Left, Center or Right as the justification of the bar code 
within the bounding box.

Show readable text -Choose Below or Above if you want the data that encodes 
the bar code to appear as readable text along with the bar code.

Checksum list -This property controls how the checksum is created. Checksums 
can be optionally added to some bar codes. See each bar code type description for 
more information.
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Ratio list -Select the ratio of the width of the bar code’s bars. This setting is 
dependent on the bar code type.

Narrow bar -Enter the width to use for the narrowest bars in the bar code.

Bar code height -Set the height of the bar code bars. This setting is only required 
by Code 49 and Code 16K type bar codes, which use fixed height bars.

PDF417 options -These settings are specific to PDF417 type bar codes. See the 
EPIDesigner Help system for more information.

Selecting Colors

Selecting Colors Using the Attribute Bar Lists

To select colors using the Attribute bar lists, perform these steps:

1. Highlight the object using the Select tool.

2. To change the line color, select any of the sixteen quick-access colors from the 
Line Color list in the Attribute Bar.

To change the fill color, select any of the sixteen quick-access colors from the 
Fill Color list in the Attribute Bar.

To change the text color, select any of the sixteen quick-access colors from the 
Text Color list in the Attribute Bar.

Creating Your Own Colors
To create your own colors and apply them to screen elements, perform these steps:

1. Double-click the object to open the Properties dialog box. On the General tab, 
click the ellipsis buttons next to either Line Color, Fill Color or Shadow. The 
Color dialog box appears.
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Figure 25  Expanded Color dialog box

2. Drag the cursor in the color refiner box and the arrow beside the luminosity bar 
to define your color. You can also create a color by typing numbers in the Red, 
Green and Blue boxes, or in the Hue, Sat (saturation), and Lum (luminosity) 
boxes.

Note: The color you create is shown in the left side of the Color/Solid box. 
You can double-click the right side of the box, or press ALT+O, to use the solid 
color that most closely resembles the one you have created.

3. In the Custom Colors palette, select an empty box for the new color, or select a 
color that you want to change.

4. Click Add to Custom Colors.

Note: The custom color list is saved in the layout (DGN) file so that you can 
maintain a consistent color scheme in each card layout.

5. Create any other colors you want and add them to the palette.

6. Click OK.

Placing Objects on the K and O Planes

EPIDesigner supports 24-bit color, with output process colors, in the following 
models: CMY (cyan, magenta and yellow), CMYO (CMY plus a protective 
overlay); CMYK (CMY plus pure black), and CMYKO (CMYK plus a protective 
overlay). Each color is considered a “plane”.

CMYK For CMYK, ribbon-based ID card printers will use individual ribbons or ribbon 
segments for each process color. Some color document printers, like the HP 
DeskJet 560C, have a CMY ink cartridge and a pure black (K) ink cartridge. As 
the card is passed through the printer, each plane is applied to the card in such a 
way that it is combined with the other planes to achieve a desired color. For 
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example, if you were to print process black on a card, the printer would combine 
100% of the cyan, magenta, and yellow planes to achieve black. By contrast, pure 
or resin black (which is much richer) is achieved by printing 100% of the K plane.

Place Objects on the K Plane

To place objects on the K Plane, perform these steps:

1. Double-click the object you want place on the K plane. The <object> 
Properties box opens. 

2. Click the General tab.

3. Click Print on K Plane.

Note: This option is only valid if your card printer supports K plane printing.

The O Plane or Protective Overlay

The O Plane, or protective overlay, is a transparent film on a separate ribbon (the 
O plane), which is applied after the other colors have been printed onto the card. It 
is used to protect the card from wear and tear. It is not technically a color, but it is 
treated as such by printers that offer protective overlay printing as an option. 

Note: This option will only work with certain printers. Please consult your 
printer documentation for information on setting up options and exclusion areas 
to apply a protective overlay to your card design.

Setting Up Magnetic Stripe Information

Use Magnetic Stripes to Retrieve Cardholder Data

EPIDesigner allows you to encode virtually any data you want on the Magnetic 
Stripe, which is particularly helpful if you are creating items such as credit cards, 
ATM cards, long distance telephone cards, or public transportation access cards.

Allowable Track
Information

The following table illustrates the type of information that may be encoded to each 
track of the Magnetic Stripe:

Track Bits per Inch No. of 
Alphanumerics No. of Numerics

1 210 76

2 75 37

3 210 104
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Track 1 allows alphanumeric (both alphabetic and numeric) characters, and Tracks 
2 and 3 only permit numeric characters. Certain character sets are accepted for 
encoding on each track. For more information on allowable character sets, refer to 
the documentation that accompanies your Magnetic Stripe encoding module.

The printer automatically verifies whether or not a card has been successfully 
encoded. Depending on your printer’s features, if a card is not encoded properly, 
the printer ejects the blank card and the on-line LED flashes. If this occurs, 
reexamine the information you have selected for encoding and make the necessary 
modifications to your track layout.

Note: You do not need to add special data characters to signify Start Sentinels, 
End Sentinels, and Field Separators (as defined by ISO 7811-2 standards). 
EPIDesigner will add these characters automatically during the encoding 
process.

Set Up Magnetic Stripe, Smart Chip or Proxy Encoding

To set up Magnetic Stripe, Smart Chip, or Proxy Encoding, perform these steps:

1. On the File menu, click Layout Properties.

2. Click the General tab, then click Encoding. The Card Encoding dialog 
appears.

Figure 26  Card Encoding dialog

3. From the Tracks list, select the type of technology that can be read by your 
card reader. For magnetic stripe encoding, refer to your hardware documen-
tation to find out which tracks are supported by your particular device.
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4. From the Field/Expression list, select any available data field (or create an 
expression) that you want to encode. See “Defining Expressions” on page 1.45. 
for more information.

5. Click Add Field. Your selection appears in the Selected Text Fields list.

6. Repeat steps 3 and 4 for each data field or expression that you want to encode.

7. For magnetic stripes, repeat steps 1 to 4 to encode additional tracks.

8. When you are finished, click OK.

The track layout information is saved to your card design when you choose Save 
or Save As from the File menu. The physical encoding of the magnetic stripe 
occurs when you print or externally encode the card from your application.

Remove Individual Fields/Expressions from the Layout

To remove individual fields/expressions from the layout, perform these steps:

1. From the Tracks list, select the track or technology from which the database 
field or expression is to be removed. 

2. Select the data field or expression from the Selected Text Fields list.

3. Click Remove Field.

Remove all Fields and Expressions from the Track Layout

To remove all fields and expressions from the layout, perform these steps:

1. From the Tracks list, select the track from which all of the database fields and 
expressions are to be removed.

2. Click Clear Fields.
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Tips and Tricks

Creating Your Own Card Backgrounds

There are plenty of software packages available that offer high resolution bitmap 
images that can be used as card backgrounds. If you would like to develop your 
own company-specific backgrounds, there are a few points to remember.

• Use a sophisticated paint program to design your card backgrounds, and save 
them in a bitmap or JPEG file format that is recognized by EPIDesigner. While 
Microsoft Paint is an adequate tool for some kinds of graphic design, it does not 
offer the creative effects (such as gradient fills or artistic text) that can give your 
artwork a professional quality.

• To assure your custom card background graphic will not be cropped during 
import, always set the size of your card background to the page size of the 
medium onto which you will be printing (for example, 80mm long by 54mm 
high). Also, set the output resolution to at least 300 dots per inch, with a 24-bit 
(16 million) color setting: line art should have a higher dpi for the best quality, 
and photographs can be a bit lower than 300 dpi without significant degradation 
in quality. 

• If you prefer to use a draw program, export your card background graphic with a 
one-to-one pixel setting. Set the output resolution to at least 300 dots per inch 
with a 24-bit color setting. If the draw program offers anti-aliasing with the 
export utility, it will smooth out the “jaggies” in your artwork.

• You can save or export your background graphic to 256 different colors to 
conserve disk space. The end result will be noticeably inferior to 24-bit color 
output. Sixteen million colors will give your card background a near-photo-
graphic quality. If disk space is an issue, save the file as a JPEG image. This file 
format offers exceptional compression, while maintaining the high quality of the 
image.

• Test-print your background design on the printer you will be using to produce 
your ID cards. ID card printers do not always output the colors you see on your 
screen. Test-printing allows you to adjust the color output to your satisfaction 
before you go into full ID card production.

Color Variation and Intensity Threshold Settings

The effects of these settings depend entirely on the tonal quality of the image that 
is being close-cropped. Images with darker background pixels, or backdrops that 
have distinct variations in shading, pose more of a problem than images with 
brighter, solid-colored backgrounds.
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For best results on close-cropping photographs, follow these image capturing tips:

• Make sure your subject is well lit. Using backlighting behind the subject 
separates the subject’s hair from the backdrop, creating a slight halo effect 
around the hair. This works well to define dark hair from a dark backdrop.

• Photograph your subjects against a solid-colored backdrop.

• If you are using the ambient lighting in an office, rather than specialized photo-
graphic lighting, place your subjects against a colorful backdrop (sky blue, red, 
or green work well). This enhances your subject's flesh tones, and makes it 
easier for EPIDesigner to differentiate the background pixels from those that 
compose the image of the cardholder.

• When you are not using cameo or ghosting effects, darker backgrounds reduce 
the intensity threshold of the image.

Nudging Objects

You can “nudge” EPIDesigner objects one pixel at a time to place them on your 
card design with precision. To do this, select the object and use your arrow keys to 
move it in the direction of your choice.

Constraining Objects

To draw perfect squares and circles, or perfectly horizontal or vertical lines, hold 
down the SHIFT key to constrain the object while you draw or resize it.

Note: Images (photographs, fingerprints and signatures) are automatically 
constrained to their proper aspect ratios when you draw or resize them on your 
card design.

Quick-Copying Objects

You can quick-copy an object by holding down the CTRL key, and selecting and 
moving the original object with your mouse pointer. This action leaves behind a 
copy of the original image at the original location. This allows you to bypass the 
Copy/Paste commands and Toolbar buttons.

Selecting/Deselecting Multiple Objects

You can select multiple objects by holding down the SHIFT key and clicking on 
the objects of your choice. Clearing objects from a previously selected group can 
be performed in the same manner.
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Another way to select multiple objects is to click and hold down your left mouse 
button, and draw a marquee box around the group of objects that you want to 
select. Be careful to not click and hold down your left mouse button while the 
pointer is located over an object, as this will select and move the object.

Selecting Individual Objects

It can be difficult to highlight an individual object when there are several objects 
overlapping one another, particularly if the object you want to select is in between 
or underneath others. An easy way to select a layered object is to press the Tab 
key on the keyboard to select each object in succession. 

Placing Bar Codes

When adding a bar code to your card design, place it so the bottom of the code is 
at least 1/4-inch from the bottom margin of the card. Most card readers are 
incapable of reading bar codes that are printed below this location. To be sure your 
bar code is in the right spot, test-print a single ID card and try it on your card 
reader.

When sizing a bar code to fit onto your card design, remember the following 
useful points:

• To see how long the bar code will be (using the default narrow bar width ratio), 
select the bar code, open the Properties dialog box and enter a sample text 
string with the same number of alphanumeric characters as you plan to use in the 
bar code. For example, if your planned bar coding sequence is 9 alphanumeric 
characters in length, enter nine sample alphanumeric characters in the Sample 
Text field. The bar code on your card design will automatically resize itself to 
accommodate the new character length.

• If the bar code is too long to fit onto your card design, select the bar code, open 
the Properties dialog box and change the Ratio option to “2.5:1” or “2:1”. This 
resizes the widest bars in the bar code by a ratio of 2.5 to 1 or 2 to 1 respectively, 
relative to the narrowest bars. The bar code on your card design is automatically 
reduced in the length.

Note: This option does not apply to all bar code types.

• If you reset your bar width ratio and you still cannot fit your bar code onto your 
card design, adjust the narrow bar width itself. To do this, open the Properties 
dialog box and enter a smaller number in the Narrow bar width field than the 
default.

• Select Show readable text to add human-readable text.

• Add a “quiet zone” (that is, a clear space with no machine readable marks in it) 
before and after the bar code.
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• If your bar code reader is not infrared, place the bar code on a white background.

Protecting Your Bar Codes Against Counterfeiting

K (resin) plane bar codes can be printed against a process black background and 
still be used by infrared card readers. Since infrared readers do not identify 
process black, this combination of pure and process blacks makes bar codes 
impossible to photocopy or scan.

For other types of bar code readers, consult your supplier for possible anti-
counterfeiting options. Intermec readers, for example, do not identify Pantone 
202; therefore, a K plane bar code printed against this color (either resin or dye) 
will still be recognized by the reader, but remains difficult to reproduce.

Using Fonts

If you are new to the concepts of proper font usage, remember these simple rules 
to great ID card typography:

• Never use more than one or two fonts in your ID card design. If using two fonts, 
be sure they complement each other. In general, combine one serif typeface and 
one sans serif typeface (for example, Times and Arial).

• If your ID card printer prints at unusually low resolutions (for example, 200 dots 
per inch or under), always use a single bold sans serif typeface (printers with low 
resolutions cannot print the thin line weights in a serif font). Set the point size to 
at least 10.

• If you are using a card background bitmap, ensure your typeface fill color makes 
your text object stand out against the background. Generally, yellow and white 
characters can be easily read against dark background colors. Try to avoid harsh 
contrasts (for example, red typography against a dark green background).

• To test if you have selected the proper typographical point size, print a sample 
card and try to read it at arm's length. If you cannot see what is written on the 
card, select a different font.
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EPIExpression Syntax

Numeric constants

Integer or floating-point decimal numbers

Examples:

0
12.34

String constants

Text strings enclosed in single or double quotes

Examples:

"abc"
'abc'

Variable names

Variable names consist of letters, numbers and the characters "_" and ".". The first 
character of the name must be a letter. When the EvaluateExpression method is 
called, EPIExpression evaluates the expression using the given values for the 
variables.

Examples:

X
Field_1

String concatenation

+
&

Text strings can be combined using either "+" or "&" operators.

Examples:

First_Name + " " + Last_Name
"Date: " & DATE()
EPIExpression Syntax - 
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Arithmetic

+
-
*
/

These operators are used to add ("+"), subtract ("-"), multiply ("*") or divide ("/") 
numbers. Multiple operations in one expression are performed according to the 
usual order of operations (multiplication and division before addition and 
subtraction), unless parentheses are used to specify a different order.

Examples:

(X + 1) / 2
PRICE * 0.15

Comparison operators

=
<>
<
<=
>
>=

The usual comparison operators can be used to compare strings or numbers.

Examples:

First_Name < "M"
IF(X = 0, "INVALID", X)

Logical operators

AND
OR

A logical expression with "AND" is true if both parts of the expression are true. A 
logical expression with "OR" is true if either part of the expression is true.

Examples:

First_Name <> "" AND Last_Name <> ""
Department = "Sales" OR Department = "Marketing"
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Functions

These built-in functions can be used in expressions. The function names are not 
case-sensitive - "DATE()", "Date()" and "date()" are all valid. Some functions 
have more than one name, for the convenience of people who are used to the 
different names.

String functions

LEFT(s, n) -Return the first n characters of the string s.

Example:

LEFT(First_Name, 1) + LEFT(Last_Name, 1)

RIGHT(s, n) -Return the last n characters of the string s.

Example:

RIGHT(Employee_Number, 3)

LTRIM(s) -Remove blank spaces from the beginning of a string.

Example:

LTRIM(First_Name)

RTRIM(s) -Remove blank spaces from the end of a string.

Example:

RTRIM(First_Name)

LCASE(s), LOWER(s) -Change all the letters in a string to lower-case. LCASE 
and LOWER are synonyms.

Example:

LCASE(First_Name)

UCASE(s), UPPER(s) -Change all the letters in a string to upper-case. UCASE 
and UPPER are synonyms.

Example:

UCASE(Card_Code)
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LEN(s), LENGTH(s), DATALENGTH(s) -Return the number of characters in a 
string. LEN, LENGTH and DATALENGTH are synonyms.

MID(s, n [, l]), SUBSTR(s, n [, l]), SUBSTRING(s, n [, l]) -Extract the portion 
of the string s starting at character position n and l characters long. The third 
argument, l, is optional. If it is omitted, return the string from position n to the end. 
MID, SUBSTR and SUBSTRING are synonyms.

Examples:

MID(Card_Code, 3, 4)
MID(Card_Code, 3)

INSTR([n,] s1, s2) -Search the string s1 for the first occurrence of the sub-string 
s2. If the optional argument n is given, it is the character position to start 
searching. Returns the character position where s2 starts, or 0 if s2 is not found in 
s1.

Example:

INSTR(First_Name, "e")
INSTR(5, First_Name, "e")

STRING(n, c) -Make a string consisting of the character c repeated n times.

Example:

STRING("x", 100)

CHAR(n), CHR(n) -Return the character with a given ASCII code. n is a number, 
and the return value is a single-character string. CHAR(ASCII(c)) equals c. 
CHAR and CHR are synonyms.

Example:

CHAR(34)

ASC(c), ASCII(c) -Return the ASCII code of a given character. ASC and ASCII 
are synonyms. ASCII(CHAR(n)) equals n.

Example:

ASC("A")
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Numeric functions

FIX(n) -Convert a number or numeric string to an integer. The result is rounded to 
the nearest integer, so for example FIX(0.99) equals 1.

Example:

FIX(Height)

FLOAT(s) -Convert a numeric string to a floating-point number.

Example:

FLOAT("3.14159")

HEX(n) -Convert an integer number to a hexadecimal string.

Example:

HEX(65)

OCT(n) -Convert an integer number to an octal string.

Example:

OCT(65)

Date and time functions

NOW() -Return the current date and time in a string.

DATE() -Return the current date in a string.

TIME() -Return the current time in a string.

YEAR(s) -Return the year from a date/time string.

Example:

YEAR(NOW())

MONTH(s) -Return the month (1 - 12) from a date/time string.

Example:

MONTH(NOW())
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DAY(s) -Return the day of the month (1 - 31) from a date/time string.

Example:

DAY(NOW())

WEEKDAY(s) -Return the day of the week (1 - 7) from a date/time string. 1 
means Sunday.

Example:

WEEKDAY(NOW())

HOUR(s) -Return the hour (0 - 23) from a date/time string.

Example:

HOUR(NOW())

MINUTE(s) -Return the minute (0 - 59) from a date/time string.

Example:

MINUTE(NOW())

SECOND(s) -Return the seconds (0 - 59) from a date/time string.

Example:

SECOND(NOW())

Other functions

IF(a, b, c) -Choose one value or another based on a logical expression. If the 
logical expression a is true (non-zero or non-empty) then return the value of 
expression b, else return c.

Example:

IF(LEN(Last_Name) = 0, "INVALID", Last_Name)

MRTD(nFormat, nLine, sDocType, sDocNum, sCountry, sNationality, 
sGivenName, sSurname, sSex, sExtra, dBirth, dExpiry) -Format the given data 
fields into a machine-readable text string according to the ICAO standard for 
machine-readable passports and travel documents.

Note: You will require additional licensing to use this command.
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Arguments:

nFormat - An integer specifying which document format to use. Possible values: 1 
= TD1, 2 = TD2 or type B visa, 3 = passport or type A visa

nLine - An integer specifying which data line to return. Possible values: 1, 2, 3

sDocType - A string specifying the type of travel document. Possible values: "P", 
"V", "A", "C", "I", or a two-letter code starting with one of these letters.

sDocNum - A string specifying the document number. Maximum length: 9 
characters

sCountry - A three-letter code specifying the country issuing the document.

sNationality - A three-letter code specifying the nationality of the person.

sGivenName - The person's given (first) name.

sSurname - The person's surname (last name).

sSex - The person's sex. Possible values: "M", "F"

sExtra - A string specifying any additional data.

dBirth - The person's date of birth.

dExpiry - The expiry date of the document.

Example:

MRTD(3, 2, Document_Type, Passport_Number, Issuing_State, Nationality, 
Given_Name, Surname, Sex, "", Birth_Date, Expiry_Date)

Result:

3141592656CAN3407127M0809306<<<<<<<<<<<<<<00

MRTDDATE(d, nLang1, nLang2) -Format the given date in the standard ICAO 
format.

Note: You will require additional licensing to use this command.

Arguments:

d - The date to be formatted.
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nLang1 - The first language to use. Possible values: 0 = default (English), 1 = 
English, 2 = French, 3 = Spanish

nLang2 - The second language to use. Possible values: 0 = default (English or 
French depending on nLang1), 1 = English, 2 = French, 3 = Spanish

Example:

MRTDDATE("June 2, 1998", 0, 0)

Result:

02 JUN /JUIN 98
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Glossary
A

Aspect Ratio The ratio of the width of an image to its height.

Attributes Characteristics assigned to objects, with respect to the line and fill. Line attributes 
include weight (thickness) and color. An object’s fill attribute is a color. Text 
objects also have attributes, such as the font (typeface), style and color.

B

Bitmap An image composed of a series of dots (pixels). Scanners and paint programs, 
such as Paintbrush, generate this type of image. By contrast, EPIDesigner creates 
images using vector objects—shapes stored internally as mathematical equations.

C

Cameo effect An artistic effect that is accomplished by removing the bitmapped image’s 
background pixels. In the case of photographs, the image backdrop will be 
removed, and a close-cropped image of the card holder will be placed against the 
card background.

Card The printed card that has been issued to the cardholder. A card can exist as a 
record in the database, even if the card itself has never been printed.

Card Background A card background is a high resolution bitmapped image that is imported into the 
card design. It serves as a scenic backdrop to the graphic objects and static or 
dynamic data that is printed on the card.

Card Format A card format is a template from which ID cards are produced. It is composed of 
an EPIDesigner card design including the card background image, design objects, 
smart chip or magnetic stripe track layout, and the printer setup information.

Card Reader A card reader is an access control hardware device used to read bar codes, 
magnetic stripes, smart chips, or microwave emissions from the different types of 
advanced security cards.
Glossary
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Constrain Holding down the SHIFT key while drawing or resizing an object, to force the 
object into a specific shape. For example, holding the SHIFT key down while you 
draw or resize a rectangle forces that object to become a perfect square. Images 
(photographs, fingerprints and signatures), when drawn, are automatically 
constrained to their proper aspect ratios (as determined in your application).

Crop Reducing or increasing the visible area of an image by using the Crop button in 
the Crop Image dialog box. The area of the image that resides within the rectangle 
will be cropped and saved to the database. The area of the image that resides 
outside the rectangle will be discarded.

Cropping Rectangle The rectangle with eight handles that signifies the cropping area over a captured 
image.

D

Directory A directory is a structure used to organize files on a disk like a drawer in a filing 
cabinet. Directories have names, and can be divided into subdirectories. For 
example, you can have a directory named CARDS to store your card designs.

Double-click To press and release the left mouse button twice in quick succession.

Drag To move the mouse while holding down the left mouse button.

Drive A device in a computer that spins disks used to store information. Personal 
computers normally have a fixed, or hard, disk (labeled C) and one or two floppy 
disk drives (labeled A and B).

Drop-down List A drop-down list allows you to choose commonly-used entries for a specific 
category of information (such as Blue, Green, Brown or Gray, if you create a pick 
list for the card holder’s eye color). This is often referred to simply as a “list”.

Dynamic Text Object A text object in a EPIDesigner card design that has been linked to a database field 
(e.g., the cardholder’s first name, last name, etc.). Unlike static text, a dynamic 
text object outputs the variable information that was entered into its associated 
field.
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E

Expression In EPIDesigner, a combination of operators, constants and names of fields that 
produce a single value. You can use expressions to combine database fields for 
magnetic stripe or smart chip encoding, or for database field links to dynamic text 
objects (e.g., the First_Name and Last_Name fields can be combined into one 
dynamic text object that prints the cardholder’s full name on a single line).

Extension Characters following the period in a filename that identify the type of information 
in the file. For example, the .DGN extension indicates that the file contains a 
EPIDesigner drawing.

F

Field Label The name which identifies the field. In EPIDesigner, a dynamic text object’s label 
can be modified in the Text field of the Dynamic Text Properties > Text tab.

G

Ghost Image An image or bitmap that is almost transparent, so that the card background can be 
seen through it.

Grid Lines A series of evenly spaced, intersecting horizontal and vertical dots used to align 
objects.

H

Handles Small squares that appear on the corners and sides of the cropping rectangle. You 
can use these handles to resize or move the rectangle over the captured image. The 
area of the image that resides within the rectangle will be cropped and saved to the 
database. The area of the image that resides outside the rectangle will be 
discarded.

Hue The position of a color along the color spectrum. For example, green is located in 
the spectrum between yellow and blue.

J

Justification The alignment of text in relation to the left, right, top and bottom margins of the 
text frame.
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L

Landscape
(Page Orientation)

A page oriented so that it prints from left to right across its longest dimension.

Luminosity The brightness of a color on a scale from black to white.

O

Orientation Refers to the direction in which print is oriented on the page. Printing across the 
width of the page is known as portrait orientation (derived from portraits of 
people, which are usually vertical in format). Printing across the length of the page 
is known as landscape orientation (derived from landscape paintings or photo-
graphs, which are usually horizontal in format).

P

Pixel Short for “picture element.” Pixels are dots on a computer screen or television that 
combine to form an image.

Point Size A unit of measurement used primarily in typesetting for designating type sizes. 
There are approximately 72 points to an inch.

Portrait
(Page Orientation)

A page oriented so that it prints from left to right across its shortest dimension.

S

Saturation The purity of a color’s hue, moving from gray to the pure color.

Static Text Object A text object in a EPIDesigner card design that has not been linked to a database 
field. Unlike dynamic text, a static text object, such as a headline or a field label, 
remains constant from card to card during the print process.

Symbol PDF417 A two-dimensional symbology that allows you to encode a Portable Data File with 
ASCII, binary, or numeric data. The Symbol PDF417 is particularly useful if you 
need to encode large amounts of data onto a limited space (e.g., an ID card that 
requires customer or employee profiles, biometric data, and personal descrip-
tions).
Badge Designer Manual for Picture Perfect v4 and Secure Perfect v6



75
T

Text Box A simple text field, which allows you to manually enter alphanumeric or numeric 
data.
Glossary
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Index
B
Bar Code

See also Bar codes
Bar Code properties

Bar Code Type
Codabar 51
Code 128 A 51
Code 128 Auto 50
Code 128 B 51
Code 128 C 51
Code 16K A 52
Code 16K Auto 52
Code 16K B 52
Code 16K C 52
Code 3 of 9 49
Code 49 52
Code 93 50
EAN 13 50
EAN 8 50
Extended Code 3 of 9 50
Extended Code 93 50
Interleaved 2 of 5 50
MSI Plessey 51
POSTNET (Zip + 4 PostalCode) 51
Symbol PDF417 51
UCC 128 51
UPCA 50
UPCE 10 digit 50
UPCE0 6 digit 50
UPCE1 6 digit 50

Checksum 52
Text 52

Bar codes
Adding 48
Drawing 48
Linking 48
Printing on K Plane 49
Properties and values 48
Setting background color 49

C
Card background

Changing color 27
Compressing images 12
Exporting 26

Importing 24
Card orientation 21
Commands

Bar Code 48
Dynamic Image 40
Text 36

D
Defining expressions 45–47

E
Enhance dialog 25
Existing card design files 22
Expressions 45

I
Images

Adding 40
Ghosting 43

L
Layout Properties command 21

M
Magnetic stripes

Setting up 55
Magnetic Stripes & Smart Chips 55–57

N
New command 22

O
Objects

Aligning 32
Attributes 34–45
CMYK 54
Distributing 32
Flipping 34
K and O Planes 54–55
Moving, copying 32
Rotating 33
Shadow 44
Static text 34

Open command 22
Options command 12, 13

P
Page Setup command 15, 16, 19

R
Rulers 12

S
Save As command 24
Save command 23
Saving card designs 23
Selecting colors 53
Selecting page sizes 21
Setting Up EPIDesigner 11

T
Text objects

Adding 35
Dynamic 37

Tips and Tricks
Bar code security 61
Bar codes 60, 61
Color Variation and Intensity Threshold

Settings 58
Creating card backgrounds 58
Fonts 61
Objects 59

V
View 11

W
Workspace

Attribute bar
Line Color list 35
Line Weight list 35

Design windows 11
Grid lines 13
Zoom In/Out 13

Edit menu 12
K Plane button 55
Text Style bar

Justify buttons 36
Toolbar 9
Undo command 12
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